Proxmox VE 8 Update danach Fehler

moonsorrox

Well-Known Member
Mar 7, 2017
206
6
58
Germany
Guten Abend,
eines meiner beiden System hat hervorragend geklappt und da dachte ich mir mache ich heute mal den 2. Proxmox.
Ich habe mich an die Update Anleitung gehalten.

Ich kann mich direkt mit Tastatur und Bildschirm anmelden, aber ich komme nicht auf die Weboberfläche.
Folgendes sehe ich auf dem Bildschirm Screenshot. Weiß aber nicht was es zu bedeuten hat.

IMG_1620.JPG
 
Ich habe mich jetzt mal mit Monitor angemeldet und die fstab angepaßt und diesen Teil hier auskommentiert
Code:
/dev/sdb /mnt/pve/omv-music ext4 defaults 0 1

jetzt startet Proxmox auch wieder auf die Oberfläche.
Mist ist eben da sind die Musikdateien drauf. Weiß jetzt aber nicht was daran falsch ist.
Bitte Tipps was ich machen kann.
 
Last edited:
Ich würde die Disk schonmal nicht mit "/dev/sdb" sondern mit /dev/disk/by-id/DieIdDeinerDisk oder der UUID dort eintragen. "sdb" ist nicht eindeutig und kann auch mal fehlen oder auf eine ganz andere Disk verweisen, was dann natürlich zu Problemen führt und wenn ein Dateisystem in deiner fstab nicht gemountet werden kann, dann verweigert gleich der ganze Server das booten: https://wiki.ubuntuusers.de/fstab/#Identifikation-der-Geraete

Wenn du denkst dein ext4 Dateisystem ist kaputt (z.B. nach Stromausfall oder Kernel Crash) könntest du mal fsck drüberlaufen lassen:
https://wiki.ubuntuusers.de/Dateisystemcheck/#Manuelle-Pruefung
 
Last edited:
ich weiß es nicht genau aber ich hatte es mal versucht ich schaue mal in die fstab da ist noch eine auskommentierte Zeile drin.
Sieht so aus
Code:
#UUID=bb1e7bfd-841f-41c1-9273-d8b5521cdebc /mnt/sdb auto defaults 0 1

Ich werde mich morgen/heute mal mit beschäftigen
 
Ich habe mich jetzt mal mit Monitor angemeldet und die fstab angepaßt und diesen Teil hier auskommentiert
Code:
/dev/sdb /mnt/pve/omv-music ext4 defaults 0 1

jetzt startet Proxmox auch wieder auf die Oberfläche.
Mist ist eben da sind die Musikdateien drauf. Weiß jetzt aber nicht was daran falsch ist.
Bitte Tipps was ich machen kann.
Hatte ich auch, liegt aber am letzten "1".
ändere den Eintrag auf "0", zB.:
Code:
/dev/sdb /mnt/pve/omv-music ext4 defaults 0 0
Grund:
PVE will einen fsck machen, bevor der Mountpoint gemountet wurde.
Somit beisst sich die Katze irgendwann in den eigenen Schweif ;)
 
Last edited:
mach mal einen manuellen fsck auf die sdb platte:

Bash:
fsck.ext4 -f -p /dev/sdb

Wenn der erfolgreich durchgelaufen ist sollte es wieder tun
 
Last edited:
@ITT
OK ich werde es mal machen, evtl auch das was Dunuin geschreiben hat, aber das hatte ich schon mal so, weiß aber nicht mehr warum es seinerzeit Probleme gab

@ubu
SSD ist jetzt aber nicht da
Code:
root@proxmox:~# df -h
Filesystem                  Size  Used Avail Use% Mounted on
udev                         14G     0   14G   0% /dev
tmpfs                       2.8G  1.3M  2.8G   1% /run
/dev/mapper/pve-root         94G   18G   72G  20% /
tmpfs                        14G   46M   14G   1% /dev/shm
tmpfs                       5.0M     0  5.0M   0% /run/lock
/dev/nvme0n1p2              511M  328K  511M   1% /boot/efi
/dev/fuse                   128M   24K  128M   1% /etc/pve
//10.0.0.30/Proxmox-Backup  2.8T  1.8T  1.1T  63% /mnt/pve/unraid-proxmox
tmpfs                       2.8G     0  2.8G   0% /run/user/0

und ein fsck.ext4 -f -p /dev/sdb sieht so aus


Code:
root@proxmox:~# fsck.ext4 -f -p /dev/sdb
/dev/sdb: Inode 8129211 extent tree (at level 1) could be shorter.  IGNORED.
/dev/sdb: Inode 8129243 extent tree (at level 1) could be shorter.  IGNORED.
/dev/sdb: Inode 9175065 extent tree (at level 1) could be shorter.  IGNORED.
/dev/sdb: Extended attribute block 32514082 has reference count 939, should be 943. 

/dev/sdb: UNEXPECTED INCONSISTENCY; RUN fsck MANUALLY.
        (i.e., without -a or -p options)
 
OK das mit der "1" tauschen hat schon mal geklappt, vielen Dank.
Wenn ich jetzt mal die UUID anschaue sehe ich das es jetzt die sdb gibt. Wenn ich bei Disks schaue sehe ich auch das sie gemountet wurde, aber ist ja logisch.

Habe sie so in der fstab drin:
Code:
/dev/sdb /mnt/pve/omv-music ext4 defaults 0 0

Sollte ich diese jetzt mit der UUID einbinden.? diese sieht so aus
Code:
UUID="354b626f-30f1-4cc6-a3a6-c7192a7eb1ad" BLOCK_SIZE="4096" TYPE="ext4"
habe ich gemacht
 
Last edited:
  • Like
Reactions: ITT

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!