[SOLVED] Proxmox VE 7.4-15 complains about a vmbr not having a card as a bridge when using VLAN


Renowned Member
Sep 14, 2012
Vitória da Conquista, Brazil
Hello everybody! Friends once again came here with something strange that is occurring in Proxmox VE 7.4-15.

I have been working since the first PVEs 6.x with dedicated servers as follows:
vmbr0 - dedicated provider WAN card bridge
vnbr1 - A bridgeless vmbr interface to a physical card like my firewall's LAN
vmbr2 - A non-bridged vmbr interface to a physical card for multiple VLANs on my firewall

The problem I'm having right now is simple, when I put a vmbr6 card in a VM (which in this case would be vmbr2 of the model above), with a VLAN 40, Proxmox complains.

I have a Proxmox VE 7.4-3 with exactly that and I can put the VLAN without problems, but in this new PVE it won't.

Does anyone know if there's a way to provide this? I have to migrate some VMs this weekend from another PVE to this one to balance the hardware.

Thanks in advance for the help.


Last edited:
My personal mistake! I checked here on the other PVE I have and I was wrong, what I have is not vmbr2 as a Linux Bridge but an OpenVSwitch Bridge.I installed the openvswitch-switch package and after that, I created an OVS-Bridge and for each VLAN created I created an OVS-InPort, that way it worked! My mistake here.


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!