Proxmox not booting when Virtualization is on

Oct 29, 2021
9
1
8
26
First I'll start with the issue I'm running into:
I've got a monitor hooked up to my Proxmox host and when booting into it normally I get the following screen:
"""
/deve/mapper/pve-root: clean, 101782/1212416 files, 4084674/48449664 blocks
"""

My understanding is that this message is popping up because of a sudden shutdown which I had to do after installing a pfSense VM that lost me connection to my Proxmox host.

I temporarily disabled IOMMU and virtualization in my BIOS and was able to boot into Proxmox without any issues to disable my VM's from booting on startup. Now when I go to turn virtualization and IOMMU back on, I'm always met with the same screen.

My issue is that the numbers in the "101782/1212416 files" don't ever seem to be incrementing which indicates nothing's happening? I have let this screen run overnight without any luck as well. Not sure what I can do to fix the issue. Note I have a Truenas VM on this host which I would very much love to not lose.

I have scoured through the forums for the past 2 days trying various things but I'm honestly not too knowledgeable on Proxmox's ins and outs, I just set it up and run my VM's and containers. Any help is much appreciated.

TLDR: Proxmox boots when virtualization and IOMMU are disabled in BIOS but not when they are enabled
 
Hey,
/deve/mapper/pve-root: clean, 101782/1212416 files, 4084674/48449664 blocks
this message only means that your filesystem is in good shape. AFAIK this message is generated by fsck, which checks your filesystem on boot for any inconsistencies.

Did you by any chance try to passtrhough your GPU and have some configuration of that leftover?
 
Have you tried activating only one at a time? I'm guessing it's IOMMU.
 
Hey,

this message only means that your filesystem is in good shape. AFAIK this message is generated by fsck, which checks your filesystem on boot for any inconsistencies.

Did you by any chance try to passtrhough your GPU and have some configuration of that leftover?
I passed through my NIC to a new pfSense VM and at that point I lost connectivity to my Proxmox host. I restarted my host and kept getting this screen. I went and turned off SVM and IOMMU to boot into Proxmox just so I could delete the pfSense VM hoping it'd solve the issue - but it does not. When I enable SVM and IOMMU, I'm met with the same screen.

I also tried to enable SVM and keep IOMMU disabled that also didn't work.

Right now, I have left it Proxmox in the "cleaning" stage overnight hoping that it would finish cleaning files and then boot up but the file numbers don't seem to be showing any progress.

Should I disable SVM, boot into Proxmox, make backups of my VM's, and then do a clean install of Proxmox and afterwards restoring my VM's ? Or other are other solutions?
Note: I only have 1 VM on this node I care about, my Truenas VM. I likely wouldn't by backing up any of the others. (If it matters my Truenas VM also has 2 HDD's passed through to it).
 
Last edited:
I passed through my NIC to a new pfSense VM
You really don't need to passthrough the entire NIC to pfSense. when you assigned vtnet0=vmbr1=ens0f0 and vtnet1=vmbr2=ens0f1, for example, all you need to do is plug the Ethernet cable in...it will automatically passthrough without the need to passthrough the entire NIC.
 
You really don't need to passthrough the entire NIC to pfSense. when you assigned vtnet0=vmbr1=ens0f0 and vtnet1=vmbr2=ens0f1, for example, all you need to do is plug the Ethernet cable in...it will automatically passthrough without the need to passthrough the entire NIC.
I now realize that after all the posts I've read on the forum AFTER I ran into this problem. Serves me right for not researching before doing it. But thank you for the tip, I'll be sure to do that whenever I can get my Proxmox host restored and try to make my pfSense VM again.
 
Have you tried activating only one at a time? I'm guessing it's IOMMU.
Update: Tried to enable only SVM and keep IOMMU disabled and I'm able to boot into Proxmox. But whenver I enable IOMMU I'm stuck at the same "cleaning" screen.

I'm not even too sure what IOMMU is used for, would I need it enabled if I want to to passthrough HDD's to my NAS VM or a GPU to Jellyfin container or NIC to pfSense?
If I do need IOMMU for these sorts of tasks, how can I go about resolving the issue that I can't boot into the system with it enabled?
 
I'm not even too sure what IOMMU is used for, would I need it enabled if I want to to passthrough HDD's to my NAS VM or a GPU to Jellyfin container or NIC to pfSense?
If you plan to do those, you'll need IOMMU enabled. What hardware are you using? Does it have VT-d or hardware virtualization enabled in the BIOS?
 
If you plan to do those, you'll need IOMMU enabled. What hardware are you using? Does it have VT-d or hardware virtualization enabled in the BIOS?
Sorry for the late response, I've already got virtualization enabled - it's an AMD CPU (Ryzen 3600) so the setting is called SVM I believe.

After trying tons of things from various posts I wasn't able to get IOMMU enabled and actually boot into Proxmox, I ended up delaying it until I can find a solution. If you've got any suggestions to try out, I'd appreciate that. Thanks
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!