Proxmox keeps restarting when restoring large VM from backup.

Jun 18, 2023
Hi, I reinstalled Proxmox on a new drive and I now need to restore my VM's from backup. I have them as an SMB share mounted where the backups were sent to and where they are getting restored to.

Kernel information: Linux 5.15.107-2-pve #1 SMP PVE 5.15.107-2 (2023-05-10T09:10Z)

PVE manager: pve-manager/7.4-3/9002ab8a

I have an enterprise subscription and everything is up to date.

The first VM which is 40GB restored quite quickly and is up and running, the next 2 VM's are both 2TB in size. I attempted to restore one, it got to about 30% or so and failed as the machine restarted midway through, no idea why this happened.

So a second attempt was tried, it got to 40%, and same thing, restarted midway through. All progress lost.

Third attempt, same thing, reached exactly 40% (500GB or 512GB or so) and it restarted, except this time I guess something went wrong as the machine was still powered on, but the web interface wasn't working and neither was SSH. I had to manually power the machine on and off. These are getting restored to a 4TB LVM-Thin pool, so space definitely isn't an issue.

Three times this failed and I had to delete the incomplete VM and start again, and it takes a really long time (5 hours or so each run) only for it to fail because Proxmox keeps abruptly restarting and it takes me right back to square one. Are large VM's unsupported or something? This is really strange.

Could I please receive some help so I can restore these VM's and get them running again. It looks like it can't get past the 500GB mark for whatever reason.
Hi again, I tried this a 4th time and it reached 23% before I noticed that Proxmox had completely froze up. Web interface was frozen, the SSH terminal I had open was also frozen. I had htop open in the SSH terminal to monitor uptime, and saw it wasn't progressing anymore,

I then physically went over to the machine and clicked enter on the keyboard and got nothing back. So I hard rebooted it by holding down the power button.

I have just switched over to Kernel: "Linux 6.1.15-1-pve #1 SMP PREEMPT_DYNAMIC PVE 6.1.15-1 (2023-03-08T08:53Z)" and will try again for a 5th time and see how it goes. In the meantime if there are any other suggestions I would appreciate it.

I did see a message pop up on my screen "CIFS: VFS: parse_server_interfaces: malformed interface info" but the restore kept going for about another hour after this or maybe even more, so I am unsure if this is related as I doubt this would cause Proxmox to completely freeze up / reboot by itself.


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!