Proxmox issue on grub boot

killmasta93

Renowned Member
Aug 13, 2017
966
56
68
30
Hi,

I was wondering if someone could shed some light on the issue im having. currently running HP gen dl 380 gen 9 with HBA using p440ar. i installed with 4 disks 2tb the OS and it installs good. once it boots shows me the grub rescue. i put the bios in legacy mode so not sure why its saying rescue mode?

when i try ls i get this

hd0 (hdo,gpt3) (hdo,gpt2) (hd0,gpt1) (hd1) (hd2) (hd3) (hd4) (hd5) (hd6) (hd7) (hd8) (hd9)

Thank you
 
hi,

installed with 4 disks 2tb the OS and it installs good. once it boots shows me the grub rescue.

which settings did you use for the filesystem while installing? the fact that it goes into grub rescue probably means that grub wasn't installed correctly.
 
Thanks for the reply, i installed normally with ZFS raid 10 i went to the BIOS changed to legacy i was reading a few threads and say that might be issue of the HBA card but not sure what i can do. Currently had to put the OS on ext4 and the other pools in ZFS but worried that the OS disk fails and i have downtime
 
we recently changed the boot manager for zfs installs. it should be using systemd-boot if you did a UEFI install.

so if you did a UEFI install and then changed to legacy mode in BIOS, that's definitely not gonna work.

i was reading a few threads and say that might be issue of the HBA card but not sure what i can do.

possibly. a colleague tells me that the HBA mode of HP raid controllers are somewhat problematic. to be on the safe side, you can try switching the HP raid controller for a real HBA controller (flashed to IT mode). you can search in forum for some other threads where this was discussed.
 
Thanks for the reply
we recently changed the boot manager for zfs installs. it should be using systemd-boot if you did a UEFI install.
i also tried changing the bios to uefi and install proxmox uefi mode when it boots it goes into a bootloop with the logo of the HP or did i do something wrong? i guess changing it to H240 would remove this headache, but funny how its one part working with ZFS and the other part is on EXT4 because it cannot boot on ZFS
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!