Proxmox in ESXi. VMs have no access


New Member
May 30, 2023
I'm trying out Proxmox and is anything extra needed to run Proxmox under ESXi as I am unable to get any VMs in Proxmoxto talk to the outside world.

In trying to trace the DHCP requests, it looks like they are not leaving Proxmox. I see them generated and can trace them on the vmbr0/ens192/tap100i0 bridge but don't see them anywhere else. Not on the DHCP server. Not passing through any other VMs on the same ESXi virtual switch as Proxmox.

From the UI I was able to run updates, so that's connected. I can ssh in and from there talk to the world. It's just a (simple) VM that can't.

The VMs I've tried are the bare minimum. An ISO image to boot from, a disk to write to and a network device.

It's obviously something so blindingly simple, but I just can't see it.
It's obviously something so blindingly simple, but I just can't see it.
Yep, it was.

I knew I had to set Promiscuous mode on the vSwitch. I didn't know I also had to set Allow Forged Transmits.

Duhhh. :oops:
I have a similar issue, the DHCPREQUEST leaves the inner VM, through Proxmox, through the VMware host to an off-host DHCP server on my LAN.

That DHCP server responds with a DHCPOFFER, and I can see in the tcpdump response, that the DHCP server has responded with an IP for the Proxmox guest VM, including its MAC address.

The DHCPOFFER reaches the VMware host -> Proxmox VM, and I can see that it hits ens160 -> vmbr0, but it never gets into the tap for the guest VM.

I can see the packets successfully going out, then coming all the way back in, until it should be sent into the guest's tap, but never does.

Now, if I assign that same guest VM a static IP and gateway on my LAN, it works perfectly. No hacks, no weird routing rules, no firewall rules (firewalls are completely disabled on vm -> proxmox -> vmware). This proves that the L2 network is working as designed.

Why does the DHCPOFFER coming back from the DHCP server not get routed into the tap inside Proxmox? I've tried enabling proxy_arp for every interface, promiscuous mode is enabled on every interface (on or off, no change in behavior), ip_forward is on, and still no luck.

Thoughts? Ideas?


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!