[SOLVED] Proxmox GUI No Longer Works

DJ Shrug

Feb 16, 2016
My Proxmox node has suddenly stopped showing the web GUI. I'd like to figure out how to fix it. When navigating to the IP, I'm met with this blank page:

<!DOCTYPE html>
    <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
    <meta http-equiv="X-UA-Compatible" content="IE=edge">
    <meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1, user-scalable=no">
    <title>Node - Proxmox Virtual Environment</title>
    <link rel="icon" sizes="128x128" href="/pve2/images/logo-128.png" />
    <link rel="apple-touch-icon" sizes="128x128" href="/pve2/images/logo-128.png" />
    <link rel="stylesheet" type="text/css" href="/pve2/ext6/theme-crisp/resources/theme-crisp-all.css" />
    <link rel="stylesheet" type="text/css" href="/pve2/ext6/crisp/resources/charts-all.css" />
    <link rel="stylesheet" type="text/css" href="/pve2/fa/css/font-awesome.css" />
    <link rel="stylesheet" type="text/css" href="/pve2/css/ext6-pve.css?ver=5.4-13" />
    <script type='text/javascript'>function gettext(buf) { return buf; }</script>
    <script type="text/javascript" src="/pve2/ext6/ext-all.js"></script>
    <script type="text/javascript" src="/pve2/ext6/charts.js"></script>
    <script type="text/javascript" src="/pve2/js/u2f-api.js"></script>
    <script type="text/javascript" src="/pve2/js/qrcode.min.js"></script>
    <script type="text/javascript">
    Proxmox = {
    Setup: { auth_cookie_name: 'PVEAuthCookie' },
    defaultLang: 'en',
    UserName: '',
    CSRFPreventionToken: 'null'
    <script type="text/javascript" src="/proxmoxlib.js?ver=1.0-28"></script>
    <script type="text/javascript" src="/pve2/js/pvemanagerlib.js?ver=5.4-13"></script>
    <script type="text/javascript" src="/pve2/ext6/locale/locale-en.js"></script>

    <script type="text/javascript">
    if (typeof(PVE) === 'undefined') PVE = {};
    Ext.History.fieldid = 'x-history-field';
    Ext.onReady(function() { Ext.create('PVE.StdWorkspace');});

    <!-- Fields required for history management -->
    <form id="history-form" class="x-hidden">
    <input type="hidden" id="x-history-field"/>

pveversion -v
proxmox-ve: 5.4-2 (running kernel: 4.15.18-21-pve)
pve-manager: 5.4-13 (running version: 5.4-13/aee6f0ec)
pve-kernel-4.15: 5.4-9
pve-kernel-4.15.18-21-pve: 4.15.18-48
pve-kernel-4.15.18-9-pve: 4.15.18-30
pve-kernel-4.13.13-6-pve: 4.13.13-42
pve-kernel-4.13.13-5-pve: 4.13.13-38
pve-kernel-4.13.13-2-pve: 4.13.13-33
corosync: 2.4.4-pve1
criu: 2.11.1-1~bpo90
glusterfs-client: 3.8.8-1
ksm-control-daemon: 1.2-2
libjs-extjs: 6.0.1-2
libpve-access-control: 5.1-12
libpve-apiclient-perl: 2.0-5
libpve-common-perl: 5.0-55
libpve-guest-common-perl: 2.0-20
libpve-http-server-perl: 2.0-14
libpve-storage-perl: 5.0-44
libqb0: 1.0.3-1~bpo9
lvm2: 2.02.168-pve6
lxc-pve: 3.1.0-7
lxcfs: 3.0.3-pve1
novnc-pve: 1.0.0-3
proxmox-widget-toolkit: 1.0-28
pve-cluster: 5.0-38
pve-container: 2.0-40
pve-docs: 5.4-2
pve-edk2-firmware: 1.20190312-1
pve-firewall: 3.0-22
pve-firmware: 2.0-7
pve-ha-manager: 2.0-9
pve-i18n: 1.1-4
pve-libspice-server1: 0.14.1-2
pve-qemu-kvm: 3.0.1-4
pve-xtermjs: 3.12.0-1
qemu-server: 5.0-54
smartmontools: 6.5+svn4324-1
spiceterm: 3.0-5
vncterm: 1.5-3
zfsutils-linux: 0.7.13-pve1~bpo2
The HTML you get looks okay.

Do you have Javascript enabled?
Which browser are you using?

Try to empty your Browsers caches and/or try a different browser to see if it works there.
I've confirmed on some other sites that use Javascript (eg. whatismybrowser.com/detect/is-javascript-enabled or enable-javascript.com) that it isn't disabled in the 3+1 browsers I've tested:
  1. Windows Desktop Computer
    • Chrome - Version 77.0.3865.90 (Official Build) (64-bit)
    • Internet Explorer - Version 11.737.17763.0
    • Firefox - Version 69.0.2 (64-bit)
  2. Windows VM from within Proxmox node in question
    • Chrome - Version 77.0.3865.90 (Official Build) (64-bit)

I've also tried emptying cache, DNS, and incognito/inprivate modes which leads me to believe there's something wrong with pveproxy or related.

If it helps, this is what Chrome's console is outputting when it loads the page:
(index):17 GET https://node:8006/pve2/ext6/ext-all.js net::ERR_ABORTED 501 (got short file)
charts.js:1 Uncaught ReferenceError: Ext is not defined
    at charts.js:1
(anonymous) @ charts.js:1
proxmoxlib.js?ver=1.0-28:2 Uncaught ReferenceError: Ext is not defined
    at proxmoxlib.js?ver=1.0-28:2
(anonymous) @ proxmoxlib.js?ver=1.0-28:2
pvemanagerlib.js?ver=5.4-13:381 Uncaught ReferenceError: Ext is not defined
    at pvemanagerlib.js?ver=5.4-13:381
(anonymous) @ pvemanagerlib.js?ver=5.4-13:381
locale-en.js:1 Uncaught ReferenceError: Ext is not defined
    at locale-en.js:1
(anonymous) @ locale-en.js:1
(index):36 Uncaught ReferenceError: Ext is not defined
    at (index):36
(anonymous) @ (index):36
  • Like
Reactions: DJ Shrug
Great. Can you please mark the thread as solved?
  • Like
Reactions: DJ Shrug


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!