proxmox-backup-client list... Error: permission check failed.

Nov 27, 2023
5
0
1
hi, i'm trying to to run a 'proxmox-backup-client list --repository "<datastore>" --ns "<namespace>"' to get the current list of backup groups in a given namespace.
however, whatever i tried, i'm persistently getting a "Error: permission check failed." on return.
the pbs is hosted, aka i don't have root@pam access but i in fact got a fully equipped <user>@pbs account with roles "Admin" and "RemoteAdmin" from path "/".
i separated the login- and the list-calls to proxmox-backup-client and can confirm that the login of <user>@pbs succeeds.
i even tried a <user>@pbs!<token>, again with roles "Admin" and "RemoteAdmin" from "/", login-call succeeds, list-call fails.
i finally asked the hoster to do the list-call as root@pam and they get the expected listing.
anyone seen/experienced this before? any ideas?
thanks peter

ps. Backup Server 2.4-3
 
Last edited:
does it work if you include the user in the '--repository' argument? (describes like here: https://pbs.proxmox.com/docs/backup-client.html )

otherwise, can you ask what the exact acl entries for your users are?

EDIT: also does maybe a 'snapshot list' work?
 
Last edited:
hi dominik, thanks for looking into this.
yes, i included almost everything into the "--repository" parameter, aka <user>@pbs@<host>:<datastore>, for all calls.
...and obviously managed to name a wrong ip-address for the target pbs, on a host that features a couple of public ip-addresses.
so, my mistake, it's working now.
thanks peter
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!