[SOLVED] proxmox-backup-client incl. mounted drives/partition and exclude specific folder

danman

New Member
Jun 5, 2021
3
0
1
36
Hey

I'm playing a little bit with the pbs on pve.

I have a laptop which has the following mount points:
1. /
2. /boot/
3. /home/

I would like to run one command as root to include every mount points. / has a .pxarexclude file so /home/dan/ has.
Separately it's working fine but trying to use the flag
Code:
--include-dev /home/dan/ --include-dev /boot/ --include-dev /
or
Code:
--all-file-systems
doesn't catch the .pxarexclude file of each mount points.

What am I missing here?

Thanks
Dan
 
Last edited:

dcsapak

Proxmox Staff Member
Staff member
Feb 1, 2016
5,852
613
133
32
Vienna
can you post the complete commandline you use, as well as the pxarexclude files ?
 

danman

New Member
Jun 5, 2021
3
0
1
36
Hey

At the moment I'm using for each mount point this command:
Code:
proxmox-backup-client backup dan.pxar:/ --repository root@pam@192.168.50.176:8007:8tb --verbose --skip-lost-and-found
Code:
proxmox-backup-client backup dan.pxar:/home/dan/ --repository root@pam@192.168.50.176:8007:8tb --verbose --skip-lost-and-found
and I tried to add the flags above by using the first command.

pxarexclude for root:
Code:
# # <- is a comment
# ! <- Includes the filer/folder Example: !/root/
# \ <- Is used to escape special glob characters
# ? <- Matches any single character.
# * <- Matches any character, including an empty string
# ** <- Is used to match subdirectories. It can be used to, for example, exclude all files ending in .tmp within the directory or subdirectories with the following pattern **/*.tmp
# [...] matches a single character from any of the provided characters within the brackets. [!...] does the complementary and matches any single character not contained within the brackets.
#       It is also possible to specify ranges with two characters separated by -. For example, [a-z] matches any lowercase alphabetic character and [0-9] matches any one single digit.

/dev/*
/lib/*
/bin/*
/lib64/*
/sbin/*
/proc/*
/sys/*
/tmp/*
/run/*
/mnt/*
/media/*
/lost+found
/var/cache/pacman/pkg/*

# Testing
#/home/dan/.cache/*
#/home/dan/Desktop/*
#/home/dan//Downloads/*
#/home/dan//Documents/*
#/home/dan//Pictures/*
#/home/dan//.local/share/Trash/*
#/home/dan//.local/share/baloo/*
#/home/dan//.ccnet/*
#/home/dan//.cargo/*

and for my home:
Code:
/.cache/*
/Desktop/*
/Downloads/*
/Documents/*
/Pictures/*
/.local/share/Trash/*
/.local/share/baloo/*
/.ccnet/*
/.cargo/*
 

dcsapak

Proxmox Staff Member
Staff member
Feb 1, 2016
5,852
613
133
32
Vienna
could you try the exclude files without the leading slash ? (e.g. instead of '/.cache/*' use '.cache/*' ) ?
 

Fabian_E

Proxmox Staff Member
Staff member
Aug 1, 2019
988
136
43
Hi,
could you try the exclude files without the leading slash ? (e.g. instead of '/.cache/*' use '.cache/*' ) ?
won't that exclude matches recursively (e.g. /other/path/.cache/file) ?

@danman could you also share the output of pveversion -v on PVE and proxmox-backup-manager versions on PBS?
 

danman

New Member
Jun 5, 2021
3
0
1
36
It worked now! o_O

But I haven't tried the flag --all-file-systems.

I used this:
Code:
proxmox-backup-client backup dan.pxar:/ --repository root@pam@192.168.50.176:8007:8tb --verbose --skip-lost-and-found --include-dev / --include-dev /boot/ --include-dev /home/dan/
And .pxarexclude in / only.

Maybe it works because of this ...

@Fabian_E
I updated PVE and PBS to the newest version.
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE and Proxmox Mail Gateway. We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!