Proxmox Backup Client: bookworm repo on bullseye systems?

Oct 28, 2013
302
46
93
www.nadaka.de
Hi there,

we just upgraded our PBS to version 3. And we run a couple of Debian bullseye systems with Proxmox Backup Client. Is it safe to change the Proxmox repo to bookworm on a bullseye system, or should we wait until we upgrade the entire system?

Thanks and greets
Stephan
 
There is no PBS3 backup-client for bookworm but it should be fine to backup from a PBS2 backup-client to a PBS3 server. I would only upgrade the backup-client repo when upgrading the whole guest to Debian 12.
 
ah, so you mean, there is no http://download.proxmox.com/debian/pbs-client bookworm InRelease? I didn't try it yet.
There is, but it is only meant to be used with a Debian 12 Bookworm VM/LXC/host, not with a Debian 11 Bullseye VM/LXC/host. Maybe it will work, but it isn't officially tested, so I would try to avoid mixing the repos so you don't run into problems (dependencies and so on).

The bookwork repo will ship "proxmox-backup-client: 3.0.1-1" while the bullseye repo only "proxmox-backup-client: 2.4.1-1".
 
Last edited:

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!