Proxmox Android App NoVNC failure


New Member
Feb 11, 2023
Good day all,

I'm attempting to use the console in the Proxmox Android App. When selecting NoVNC both for the host and a VM, I get a black white screen.

I've tried updating my SSL cert using "pvecm updatecert --force" with no luck.

Any pointers?

Does that work if you are browsing your Proxmox VE server in the normal browser on your Android?
Do you mean Firefox in the Android itself right?

By the way, I tested it on my Android app, and works well. The questions are:
1. Are you using ACME Certificate in your PVE?
2. Have you tried to trust the PVE certificates from your device?
3. Could you please try with a different browser, i.e., the default browser on your Android device?
I can access the console successfully using noVNC using Firefox both in Android and Windows. Using the android default browser, I can also access VMs with noVNC. I didn't realize that there was a mobile webpage for proxmox. Very cool! Thanks for the awesome product!

I'm using the default certificate and have accepted the certificate when logging in via webpage.
I have the same issue. I use a valid ACME certificated accepted by browsers but te app does not accept it. I need it to be accepted in order to use no NC, no I'll thank any idea.



The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!