Proxmox 8 vmbr0 bridged port issue

backkherozzo1985

Active Member
Mar 25, 2014
16
0
41
Hi, I installed a brand new Proxmox 8 server and I'm trying to configure a vmvr0 with bridged port to the physical interface of the Proxmox server, this configuration works on Proxmox 7 where I've 2 public ip, 1 for the physical server and the other one for the pfsense vm hosted inside Proxmox. After applying the interfaces configuration the physical interface no longer has an ip assigned. Can you help me to solve this issue? You can find attached the interfaces configuration file. Thank you
 

Attachments

  • interfaces-test.txt
    1.4 KB · Views: 22
Hi, thank you for your reply! No I bought an additional public ip with separate MAC address, physical interface have 1 public ip and vmbr0 se second with separate MAC. Thank you
 
In this case you don't need a bridge-ports i.e, get rid of `bridge-ports enpXs0` line in the network config.

Code:
auto vmbr0
iface vmbr0 inet static
    address  X.X.X.X
    netmask  255.255.255.224
    gateway  X.X.X.X
#    bridge-ports enpXs0
    bridge-stp off
    bridge-fd 0
    post-up echo 1 > /proc/sys/net/ipv4/ip_forward
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!