Proxmox 8 Installer screen

Mar 14, 2021
88
27
23
44
I have been searching for a solution for a few weeks on and off now. I have tried some instances of manually setting nomodeset, vga, etc. options in the kernel boot parameters. I have even tried using the tui nomodeset advanced option. The tui nomodeset advanced option kept losing its mind on the disk selection so I stopped using it.

I am trying to install proxmox 8 on a zimaboard. The zimaboard bios settings are configured for uefi only. All I did was boot proxmox 7.4-1.iso and then boot proxmox 8.0-2.iso back to back to ensure that the issue was not entirely hardware specific.

If I boot proxmox 7.4-1.iso the installer screen looks like this
ss1.jpg

I can see and click the buttons.

From the 7.4-1.iso if I simply abort the installer and reboot into the 8.0-2.iso the screen looks like this
ss2.jpg

I can no longer see the buttons but I can tab to them and press enter to make a selection. Sometimes I end up hitting previous or abort when trying to shoot the buttons in the dark with the tab and enter keys.

Is there something that can be done to remedy this? I have been at this with researching and testing and the 8.0-2.iso just refuses to show the buttons on screen. I have even attempted multiple boot options (usb flash drive, ventoy, usb optical drive) and the proxmox 8 iso just will not show the full screen.
 
Hi generalproxyuser,

Does the Proxmox-installer have a text mode? Does it suffer the same symptoms? It may not solve the problem with the graphical install, but at least you can get going. Another workaround would be of course to install 7.4 and then upgrade.

As for the cause of the behaviour you mention: I have no idea!
 
I tried using the tui installer option but it kept losing its mind whenever I attempted to select my ssd to install to. It kept wanting to latch on to the emmc (mmcblk) even though I was selecting the ssd. On top of that, the ssd I am using is a 250gb size and while I have tested it in other systems to be above 230gb the tui installer insisted my ssd was only capable of 23.x gb file size. In fact, the tui installer at the disk size section refused to accept any number higher than two digits. The tui was just acting weird. I was afraid of having to do a 7.4 to 8 upgrade but looks like that's the most sane way forward.
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!