Proxmox 7 on GCP Connection refused

n3services

New Member
Jul 6, 2022
1
0
1
Good day,
I've installed Proxmox 7 on a GCP VM. As required by Google the VM is an n1-standard instance with Intel Haswell or later CPU based on a Debian 11 image with virtualization enabled.
Virtualization is confirmed before installing Proxmox 7 according to the instructions on https://pve.proxmox.com/wiki/Install_Proxmox_VE_on_Debian_11_Bullseye.
Host settings are as follows:
---
nico@proxmox:~$ hostname -i
10.0.25.6
nico@proxmox:~$ hostname -f
proxmox.n3services.com
nico@proxmox:~$ cat /etc/hostname
proxmox.n3services.com
---

I have noted that during the installation of proxmox-ve postfix open-iscsi the network interface gets somehow flushed and the VM is no longer reachable after the reboot post installation.
I have then configured the network interface as per https://pve.proxmox.com/wiki/Network_Configuration as follows:
---
nico@proxmox:~$ cat /etc/network/interfaces
# network interface settings; autogenerated
# Please do NOT modify this file directly, unless you know what
# you're doing.
#
# If you want to manage parts of the network configuration manually,
# please utilize the 'source' or 'source-directory' directives to do
# so.
# PVE will preserve these directives, but will NOT read its network
# configuration from sourced files, so do not attempt to move any of
# the PVE managed interfaces into external files!

auto lo
iface lo inet loopback

iface ens4 inet manual

auto vmbr0
iface vmbr0 inet static
address 10.0.25.6/24 #VM Internal IP as configured in host
gateway 10.0.25.1 #GCP VPC Gateway
bridge-ports ens4
bridge-stp off
bridge-fd 0

source-directory /etc/network/interfaces.d
source-directory /run/network/interfaces.d

nico@proxmox:~$ ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
inet 127.0.0.1/8 scope host lo
valid_lft forever preferred_lft forever
inet6 ::1/128 scope host
valid_lft forever preferred_lft forever
2: ens4: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq master vmbr0 state UP group default qlen 1000
link/ether 42:01:0a:00:19:06 brd ff:ff:ff:ff:ff:ff
altname enp0s4
3: vmbr0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
link/ether 42:01:0a:00:19:06 brd ff:ff:ff:ff:ff:ff
inet 10.0.25.6/24 scope global vmbr0
valid_lft forever preferred_lft forever
inet6 fe80::4001:aff:fe00:1906/64 scope link
valid_lft forever preferred_lft forever
---

After a restart, I can successfully reach the VM with ping on 34.74.165.148 from the internet. And I can ping any resource on the internet from the VM itself.
Everything seems to be properly up and running and there are no errors on the serial port indicating a failed service.

However, trying to reach the proxmox server via 34.74.165.148:8006 (the VM's external IP) fails and returns Connection refused.

The VPC Firewall rule allows tcp:8006 and the requests show on the firewall log. Requests are allowed and passed on to 10.0.25.6 on port 8006 as expected.

The Proxmox server also seems to listen out on port 8006:
---
nico@proxmox:~$ sudo netstat -tulp | grep 8006
tcp6 0 0 [::]:8006 [::]:* LISTEN 1328/pveproxy

nico@proxmox:~$ sudo ss -tulp
Netid State Recv-Q Send-Q Local Address Port Peer Address Port Process
udp UNCONN 0 0 0.0.0.0:sunrpc 0.0.0.0:* users ("rpcbind",pid=450,fd=5),("systemd",pid=1,fd=37))
udp UNCONN 0 0 127.0.0.1:323 0.0.0.0:* users ("chronyd",pid=529,fd=5))
udp UNCONN 0 0 [::]:sunrpc [::]:* users ("rpcbind",pid=450,fd=7),("systemd",pid=1,fd=39))
udp UNCONN 0 0 [::1]:323 [::]:* users ("chronyd",pid=529,fd=6))
tcp LISTEN 0 100 127.0.0.1:smtp 0.0.0.0:* users ("master",pid=1280,fd=13))
tcp LISTEN 0 4096 0.0.0.0:sunrpc 0.0.0.0:* users ("rpcbind",pid=450,fd=4),("systemd",pid=1,fd=36))
tcp LISTEN 0 4096 127.0.0.1:85 0.0.0.0:* users ("pvedaemon worke",pid=1322,fd=6),("pvedaemon worke",pid=1321,fd=6),("pvedaemon worke",pid=1320,fd=6),("pvedaemon",pid=1319,fd=6))
tcp LISTEN 0 128 0.0.0.0:ssh 0.0.0.0:* users ("sshd",pid=808,fd=3))
tcp LISTEN 0 100 [::1]:smtp [::]:* users ("master",pid=1280,fd=14))
tcp LISTEN 0 4096 *:8006 *:* users ("pveproxy worker",pid=1331,fd=6),("pveproxy worker",pid=1330,fd=6),("pveproxy worker",pid=1329,fd=6),("pveproxy",pid=1328,fd=6))
tcp LISTEN 0 4096 [::]:sunrpc [::]:* users ("rpcbind",pid=450,fd=6),("systemd",pid=1,fd=38))
tcp LISTEN 0 128 [::]:ssh [::]:* users ("sshd",pid=808,fd=4))
tcp LISTEN 0 4096 *:3128 *:* users ("spiceproxy work",pid=1341,fd=6),("spiceproxy",pid=1340,fd=6))
---

There seems to be something between the VPC Firewall and the Proxmox server, that blocks the traffic. I have tried to disable the pve-firewall service, but that didn't help either.

Does anyone have any idea or suggestion what is causing the connection to be refused and how to access proxmox? I am kinda at the end of my humble wisdom and would appreciate any help.

N.B: Above VM and details are just for testing to see if I can get this working. I'd prefer using proxmox instead of QEMU.
 
Last edited:

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!