[SOLVED] Proxmox 6.0.5 - WIN10 VM 100% CPU Usage when idle

jimnordb

Active Member
May 4, 2016
30
2
28
33
Code:
proxmox-ve: 6.0-2 (running kernel: 5.0.18-1-pve)
pve-manager: 6.0-5 (running version: 6.0-5/f8a710d7)
pve-kernel-5.0: 6.0-6
pve-kernel-helper: 6.0-6
pve-kernel-5.0.18-1-pve: 5.0.18-1
pve-kernel-5.0.15-1-pve: 5.0.15-1
ceph-fuse: 12.2.11+dfsg1-2.1
corosync: 3.0.2-pve2
criu: 3.11-3
glusterfs-client: 5.5-3
ksm-control-daemon: 1.3-1
libjs-extjs: 6.0.1-10
libknet1: 1.10-pve1
libpve-access-control: 6.0-2
libpve-apiclient-perl: 3.0-2
libpve-common-perl: 6.0-3
libpve-guest-common-perl: 3.0-1
libpve-http-server-perl: 3.0-2
libpve-storage-perl: 6.0-6
libqb0: 1.0.5-1
lvm2: 2.03.02-pve3
lxc-pve: 3.1.0-61
lxcfs: 3.0.3-pve60
novnc-pve: 1.0.0-60
proxmox-mini-journalreader: 1.1-1
proxmox-widget-toolkit: 2.0-5
pve-cluster: 6.0-4
pve-container: 3.0-5
pve-docs: 6.0-4
pve-edk2-firmware: 2.20190614-1
pve-firewall: 4.0-6
pve-firmware: 3.0-2
pve-ha-manager: 3.0-2
pve-i18n: 2.0-2
pve-qemu-kvm: 4.0.0-3
pve-xtermjs: 3.13.2-1
qemu-server: 6.0-7
smartmontools: 7.0-pve2
spiceterm: 3.1-1
vncterm: 1.6-1
zfsutils-linux: 0.8.1-pve1

Code:
# cat /etc/pve/qemu-server/100.conf
agent: 1
balloon: 0
bios: ovmf
bootdisk: scsi0
cores: 4
cpu: host,flags=+md-clear;+hv-tlbflush
cpuunits: 512
efidisk0: local-lvm:vm-100-disk-1,size=4M
machine: q35
memory: 4096
name: win10
net0: virtio=xxx,bridge=vmbr0
numa: 0
ostype: win10
scsi0: local-lvm:vm-100-disk-0,cache=writeback,discard=on,size=32G,ssd=1
scsihw: virtio-scsi-single
smbios1: uuid=xxx
sockets: 1
vmgenid: xxx

once i start a RDP session it goes back to 0-1%. Is this a known issue?

Windows is 10 pro with version 1903
 
Last edited:

jimnordb

Active Member
May 4, 2016
30
2
28
33
Hi,

Also take a look at this link

!'m running 18 Windows 10 Pro with Tablet = No / Spice video ( qxl ) and I see no problem.

Regards,

Ricardo Jorge
Still 100% with tablet = no and Spice. it was a good suggestion. However. I haven't seen this issue before.
 

ricardoj

Member
Oct 16, 2018
101
7
23
64
Sao Paulo - Brazil
Hi,

This is the configuration I'm using :

agent: 1
args: -device intel-hda,id=sound5,bus=pci.0,addr=0x18 -device hda-micro,id=sound5-codec0,bus=sound5.0,cad=0 -device hda-duplex,id=sound5-codec1,bus=sound5.0,cad=1
boot: cdn
bootdisk: scsi0
cores: 2
memory: 3072
name: WS-XXXXX
net0: virtio=11:22:33:44:55:66,bridge=vmbr0
numa: 0
ostype: win10
scsi0: local-zfs:vm-210-disk-0,size=32G
scsihw: virtio-scsi-pci
smbios1: uuid=XXXXXXXXXXXXX
sockets: 1
tablet: 0
usb0: spice
vga: qxl

Virtio 1.61

Ballooning is enabled but Min / Max memory have the same value.

This configuration was created on PVE 5.2X but now I'm running 6.0-5

I hope this helps.

Regards,

Ricardo Jorge
 

Vladimir Bulgaru

Active Member
Jun 1, 2019
216
55
33
36
Moscow, Russia
Hello,

Managed to solve the problem. It's an issue related to graphics driver after the 1903 update and it's a known issue.
The issue manifests after initiating an RDP session, then exiting the session without the logout of the user.

To replicate the issue:
  1. Create a Windows 10 1903 VM (CPU should be at ~0-1% idle)
  2. Access the VM via RDP connection
  3. Close the connection (CPU should be at ~20-30% idle, depending on the number of sessions and CPU settings)
Details: https://answers.microsoft.com/en-us...em-after/dbce0938-60c5-4051-81ef-468e51d743ab

The solution

As a workaround on all of my affected machines I have used Group Policy Editor to set:

Code:
Local Computer Policy
⌞ Computer Configuration
 ⌞ Administrative Templates
  ⌞ Windows Components
   ⌞ Remote Desktop Service
    ⌞ Remote Desktop Session Host
     ⌞ Remote Session Environment
      ⌞ Use WDDM graphics display driver for Remote Desktop Connections

to DISABLED

This forces RDP to use the old (and now deprecated XDDM drivers).

After the reboot, the idle should go to the normal 0-1%.
 
  • Like
Reactions: jimnordb

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!