[SOLVED] proxmox 5.4 stuck at initramfs - mounting /dev on /root/dev failed: no such file or directory

manjuv.storage

New Member
Jun 20, 2023
4
0
1
I'm unable to resolve this above subjected thread. I'm sharing screenshot. This proxmox was installed with xfs file system. Kindly help on this.
 

Attachments

  • Proxmox Error 2.jpg
    Proxmox Error 2.jpg
    158.7 KB · Views: 25
Treat it as a Linux/XFS/filesystem error rather than Proxmox problem. Search for key phrases appearing on the screen, ie "corruption of in-memory data detected". Plug it into google and try a few methods mentioned there:
https://serverfault.com/questions/8...memory-data-detected-where-does-the-issue-lie

Its possible you have hardware that have gone bad. Given 5.4 is old, I suspect hardware is no spring chicken either.
Or you could have a power loss corruption. Give the blogs/articles a try.


Blockbridge : Ultra low latency all-NVME shared storage for Proxmox - https://www.blockbridge.com/proxmox
 
Thank you for the response. As suggested, I tried to execute "xfs_repairt -L" command at initramfs, but the command is not found. Could you please suggest further troubleshooting.
 
As mentioned in the link, I booted server in Proxmox VE 5.4 installation media and choose rescue mode and tired to execute "xfs_repairt -L" command. The command is not found. Hence I reposted. Do I need to boot server using different OS like Ubuntu 20 Desktop in order to get xfs_repairt command.

Here I'm screenshot. Kindly check and help on this. Much appriciated in advance.
 

Attachments

  • 20.06.2023_08.54.52_REC.png
    20.06.2023_08.54.52_REC.png
    8.5 KB · Views: 15
The sample link is not Proxmox related and discusses a generic OS installation media that is presumed to have the necessary recovery commands.
As you discovered PVE special installer does not, so yes - do get a more suitable Live/Recovery media, ie https://help.ubuntu.com/community/LiveCD

Keep in mind, if the issue is truly bad memory, you may do more harm than good by trying to fix the filesystem while memory is defectives. Please review other articles related to the message, note that many advise running memtest (which I believe may be available from Proxmox boot options).

If the data on the disk is important, I recommend moving the disk to another machine and doing a byte-for-byte raw copy of the disk to another disk or file.


Blockbridge : Ultra low latency all-NVME shared storage for Proxmox - https://www.blockbridge.com/proxmox
 
I could able to run "xfs_repairt -L" comannd using Ubuntu Live CD and it got fixed. Now the OS is getting loaded completely. Thank you for supporting. Have a nice day. You may close this thread.
 
I could able to run "xfs_repairt -L" comannd using Ubuntu Live CD and it got fixed. Now the OS is getting loaded completely. Thank you for supporting. Have a nice day. You may close this thread.
Only you can mark this thread as solved by editing the first post. The volunteers on this forum don't have the privileges to do it for you.
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!