[SOLVED] Proxmo VE upgrade 5 to 6 ZFS Unmet dependencies

elvisgriping

Member
Aug 27, 2019
4
5
23
32
Hi All,
I just created testing cluster with two node with the latest Proxmox 5.4 and one ZFS storage. I followed the wiki with the upgrade to the version 6. Everything goes fine except the zfs.

Code:
he following packages have unmet dependencies:
 zfs-zed : Depends: zfsutils-linux (>= 0.8.1-pve2) but 0.7.13-pve1~bpo2 is installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

When I tried the apt --fix-broken install I get this issue-
Preparing to unpack .../zfsutils-linux_0.8.1-pve2_amd64.deb ...
Unpacking zfsutils-linux (0.8.1-pve2) over (0.7.13-pve1~bpo2) ...
dpkg: error processing archive /var/cache/apt/archives/zfsutils-linux_0.8.1-pve2_amd64.deb (--unpack):
trying to overwrite '/usr/share/man/man5/spl-module-parameters.5.gz', which is also in package spl-dkms 0.7.12-2
Errors were encountered while processing:
/var/cache/apt/archives/zfsutils-linux_0.8.1-pve2_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Code:
Preparing to unpack .../zfsutils-linux_0.8.1-pve2_amd64.deb ...
Unpacking zfsutils-linux (0.8.1-pve2) over (0.7.13-pve1~bpo2) ...
dpkg: error processing archive /var/cache/apt/archives/zfsutils-linux_0.8.1-pve2_amd64.deb (--unpack):
 trying to overwrite '/usr/share/man/man5/spl-module-parameters.5.gz', which is also in package spl-dkms 0.7.12-2
Errors were encountered while processing:
 /var/cache/apt/archives/zfsutils-linux_0.8.1-pve2_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Is there anyone who had similar issue?


Have a nice day and Best Regards
 
  • Like
Reactions: AlexanderR
  • Like
Reactions: AlexanderR
Thanks for your reply. But it isn't solution (please note for the testing purpose I use the pve-no-subscription repository


Code:
cat /etc/apt/sources.list

deb http://ftp.debian.org/debian buster main contrib
deb http://ftp.debian.org/debian buster-updates main contrib

# PVE pve-no-subscription repository provided by proxmox.com,
# NOT recommended for production use
deb http://download.proxmox.com/debian/pve buster pve-no-subscription

# security updates
deb http://security.debian.org buster/updates main contrib

apt full-upgrade

Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 zfs-zed : Depends: zfsutils-linux (>= 0.8.1-pve2) but 0.7.13-pve1~bpo2 is installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).


apt --fix-broken install

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following packages were automatically installed and are no longer required:
  dh-python guile-2.0-libs libapparmor-perl libbabeltrace-ctf1 libblas-common libboost-filesystem1.62.0
  libboost-iostreams1.62.0 libboost-program-options1.62.0 libboost-random1.62.0 libboost-regex1.62.0
  libboost-system1.62.0 libboost-thread1.62.0 libcephfs1 libcfg6 libevent-2.0-5 libfcgi-bin libfcgi0ldbl libfdt1
  libgfortran3 libicu57 libipset3 libjemalloc1 liblvm2app2.2 liblvm2cmd2.02 libperl5.24 libprotobuf10
  libpython3.5-minimal libpython3.5-stdlib librgw2 libtotem-pg5 liburcu4 pve-kernel-4.15 pve-kernel-4.15.18-20-pve
  python-pyasn1 python3-distutils python3-lib2to3 python3.5 python3.5-minimal rename sgml-base tcpd xml-core
Use 'apt autoremove' to remove them.
The following additional packages will be installed:
  zfsutils-linux
Suggested packages:
  nfs-kernel-server zfs-initramfs
The following packages will be upgraded:
  zfsutils-linux
1 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
725 not fully installed or removed.
Need to get 0 B/353 kB of archives.
After this operation, 148 kB of additional disk space will be used.
Do you want to continue? [Y/n] Y
(Reading database ... 116631 files and directories currently installed.)
Preparing to unpack .../zfsutils-linux_0.8.1-pve2_amd64.deb ...
Unpacking zfsutils-linux (0.8.1-pve2) over (0.7.13-pve1~bpo2) ...
dpkg: error processing archive /var/cache/apt/archives/zfsutils-linux_0.8.1-pve2_amd64.deb (--unpack):
 trying to overwrite '/usr/share/man/man5/spl-module-parameters.5.gz', which is also in package spl-dkms 0.7.12-2
Errors were encountered while processing:
 /var/cache/apt/archives/zfsutils-linux_0.8.1-pve2_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
 
  • Like
Reactions: AlexanderR
That's an odd situation - since PVE 6. (all repositories) always had zfsutils-linux in version 0.8.1.
D
spl-dkms 0.7.12-2
seems like the zfs-packages from debian upstream are installed on the system (instead of the proxmox packages)

could you post the output of `pveversion -v` and `apt update` ?

also you could try to remove the 'spl-dkms', 'zfs-dkms' packages (PVE does not ship them)

I hope this helps!
 
  • Like
Reactions: AlexanderR
Hello Stoiko,
sorry for my late reply,
here is the pveversion -v
Code:
proxmox-ve: 5.4-2 (running kernel: 4.15.18-20-pve)
pve-manager: 5.4-13 (running version: 5.4-13/aee6f0ec)
pve-kernel-4.15: 5.4-8
pve-kernel-4.15.18-20-pve: 4.15.18-46
pve-kernel-4.15.18-19-pve: 4.15.18-45
corosync: 2.4.4-pve1
criu: 2.11.1-1~bpo90
glusterfs-client: 3.8.8-1
ksm-control-daemon: not correctly installed
libjs-extjs: 6.0.1-2
libpve-access-control: 5.1-12
libpve-apiclient-perl: 2.0-5
libpve-common-perl: 5.0-54
libpve-guest-common-perl: 2.0-20
libpve-http-server-perl: 2.0-14
libpve-storage-perl: 5.0-44
libqb0: 1.0.3-1~bpo9
lvm2: 2.02.168-pve6
lxc-pve: 3.1.0-6
lxcfs: 3.0.3-pve1
novnc-pve: 1.0.0-3
proxmox-widget-toolkit: 1.0-28
pve-cluster: 5.0-38
pve-container: 2.0-40
pve-docs: 5.4-2
pve-edk2-firmware: 1.20190312-1
pve-firewall: 3.0-22
pve-firmware: 2.0-7
pve-ha-manager: 2.0-9
pve-i18n: 1.1-4
pve-libspice-server1: 0.14.1-2
pve-qemu-kvm: 3.0.1-4
pve-xtermjs: 3.12.0-1
qemu-server: 5.0-54
smartmontools: 6.5+svn4324-1
spiceterm: 3.0-5
vncterm: 1.5-3
zfsutils-linux: 0.7.13-pve1~bpo2

and apt update

Code:
Get:1 http://security.debian.org/debian-security stretch/updates InRelease [94.3 kB]
Hit:2 http://download.proxmox.com/debian/pve stretch InRelease     
Ign:3 http://ftp.cz.debian.org/debian stretch InRelease
Get:4 http://ftp.cz.debian.org/debian stretch-updates InRelease [91.0 kB]
Hit:5 http://ftp.cz.debian.org/debian stretch Release         
Get:6 http://security.debian.org/debian-security stretch/updates/main Sources [212 kB]
Get:7 http://security.debian.org/debian-security stretch/updates/main amd64 Packages [503 kB]
Get:8 http://security.debian.org/debian-security stretch/updates/main Translation-en [226 kB]
Fetched 1127 kB in 1s (1048 kB/s)                                                       
Reading package lists... Done
Building dependency tree       
Reading state information... Done
1 package can be upgraded. Run 'apt list --upgradable' to see it.

The 1 package for update is
libnghttp2-14/oldstable 1.18.1-1+deb9u1 amd64 [upgradable from: 1.18.1-1]


I will try remove 'spl-dkms', 'zfs-dkms' later today
 
  • Like
Reactions: AlexanderR
hm - that's a bit confusing?
In your posts before you had buster and pve 6.x repostories in your sources.list files - this output (pveversion and apt update) speak of stretch only?

but - removing 'spl-dkms' and 'zfs-dkms' sound like a good plan.

I hope this helps!
 
  • Like
Reactions: AlexanderR
Thanks all for cooperation's. This solved my issue-

apt-get install zfsutils zfs-initramfs

apt purge spl-dkms

I ave to apologize to Stoiko- I have installed it in virtual box with snap hosts- so I can easily revert back and check different approach.

But is it resolved now :) thanks for all your help
 
I just dealt with this upgrading my box to 6.0. This thread was helpful, but ultimately it did not provide a full solution.

The full solution, for my case, looked more like this (roughly):

Code:
# remove packages to make apt stop complaining about conflicts
apt remove spl-dkms zfs-dkms zfs-initramfs zfs-zed
# for me at least, that command also resulted in the PVE upgrade continuing,
# with some caveats:

# zfs still needs to be upgraded
apt install zfsutils-linux

# now reinstall packages needed that we removed above
# at the very least, zfs-initramfs is required or your system won't boot
#
# these should all come from PVE repos
# you may wish to verify that with `apt show` or similar first
apt install zfs-initramfs zfs-zed


# update initramfs manually, update grub, etc - just make sure things are good :)
update-initramfs -u
update-grub
grub-install /dev/dsk/by-id/$your_disk

These commands are the refined version of the mess I went through. I removed the packages, upgraded zfsutils, rebooted, figured out that my initramfs was missing ZFS, booted to an old kernel, then corrected it.

You may also want to update/reinstall grub before rebooting just to be safe (I did).
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!