Problems to set default locale with Ubuntu template

ohmer

New Member
Mar 2, 2010
27
1
3
Hello,

I read many things about setting up the default locale in Ubuntu and nothing works... my system stay in English...

How do you change your default language ?

Thanks!
 

dietmar

Proxmox Staff Member
Staff member
Apr 28, 2005
16,708
373
103
Austria
www.proxmox.com
I read many things about setting up the default locale in Ubuntu and nothing works... my system stay in English...
First, we use Debian (not Ubuntu).

How do you change your default language ?
If you talk about the web interface you can set it there.

Else try "dpkg-reconfigure locales", and set the locale in '/etc/default/locale'.
 

ohmer

New Member
Mar 2, 2010
27
1
3
Hello,

The proxmox locale is fine. My problem is with the VE template.
 

atr2006

New Member
Jun 15, 2010
2
0
1
Unfortunately, I seem to have the same problem, irrespective of the distribution I have in container (debian or ubuntu). The solution that I could find is to firstly generate files for locales in need, for instance:
Code:
locale-gen en_US.UTF-8 ru_RU.UTF-8
and then to set locale variables with:
Code:
update-locale LANG=ru_RU.UTF-8
The reboot of the container is needed for settings to take place.
 
Last edited:

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE and Proxmox Mail Gateway. We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!