problems restoring old backup pve1 => pve5

Bruno Félix

Member
Jan 24, 2017
5
0
21
51
Hi,

I have to restore a very old backup (vzdumped from a proxmox 1.9, storage local)
to a new server (bleeding edge : pve5.3, storage local-zfs)


I tried :
# qmrestore --storage local-zfs /media/usb/vzdump-qemu-102-2019_01_03-13_31_37.tgz 102

but it gives :
VM is locked (create)


I also tried :
# zcat /media/usb/vzdump-qemu-102-2019_01_03-13_31_37.tgz | qmrestore - 102 --storage local-zfs

It throws:
restore vma archive: vma extract -v -r /var/tmp/vzdumptmp6793.fifo - /var/tmp/vzdumptmp6793

command 'set -o pipefail && vma extract -v -r /var/tmp/vzdumptmp6793.fifo - /var/tmp/vzdumptmp6793' failed: got timeout


dump formats not compatible ?
is there any procedure to achieve such a messy restoration ?
any file conversion i can try ?

While not very strong (the raid1 pile died during the second vm backup)
The old (pve1) server is still available

Kind Regards

--Bruno
 
Argh, damn it :D

From this site: https://pve.proxmox.com/pve-docs/qmrestore.1.html
you have to use:
qmrestore /media/usb/vzdump-qemu-102-2019_01_03-13_31_37.tgz 102 --storage local-zfs
but i dont know if this really change anything at this, but maybe.

Do you have the Config File of the VM and can paste it here? Is the ID 102 already in use?
You can try "qm unlock 102".

Before you retry, remove all leftovers from the fault try.
 
This is a old, unsupported tar backup. You can try to manually extract the files using the standard tar command.
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!