[SOLVED] Problems on migrating container to other node in cluster


New Member
Jul 13, 2015
Hi, I set up two proxmox nodes (6.0.6) with a cluster. Now I like to live-migrate a CT (100) to the other node via webgui and ran into following error:

2019-08-28 17:26:54 starting migration of CT 100 to node 'pve0' ( 2019-08-28 17:26:55 found local volume 'local-lvm:vm-100-disk-0' (in current VM config) 2019-08-28 17:26:55 can't migrate local volume 'local-lvm:vm-100-disk-0': non-migratable snapshot exists 2019-08-28 17:26:55 ERROR: can't migrate CT - check log 2019-08-28 17:26:55 aborting phase 1 - cleanup resources 2019-08-28 17:26:55 start final cleanup 2019-08-28 17:26:55 ERROR: migration aborted (duration 00:00:01): can't migrate CT - check log

What I do not unterstand is:
a) there is a snapshot of CT100
b) why it is non-migratable?

Both nodes do have the exact same configuration (cpu, storage, ram).

Thank you for any hint on that issue!
Last edited:
Snapshots on local storage are not migratable (with the only exception being zfspool).
(neither is live-migration for containers)

I hope this explains it!
Glad this helped - please mark the thread as 'SOLVED' - it might help others who look for similar information.


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!