Problem with pct set MountPoints on Debian LXC


New Member
Jul 5, 2023
Hello everyone!

I recently installed NextCloudPi on a Debian LXC.
I also use two Synology NAS with NFS enabled.
First i added both of them to my storages in ProxMox. After that i ran:
pct set <containerId> -mp0 <path in the proxmoxhost>,mp=<path inside the container>
The Mount Point shows up in the Ressources tab of the Container. After a reboot i see the MP in /mnt/NASB but with the owner/group nobody/nogroup.
Permissions are set at r w x for everyone. When try to cd into that folder i get the Error
-bash: cd: NASB: Permission denied
I tried it with my other NAS in the same way and it works fine even tho the owner/group again matches nobody/nogroup.
I can access all of the folders in that System.

Then i tried mounting both of my NAS the same way on another container running ubuntu.
It works without a problem and has the owner/group set as root/root.

What am i missing here?

Thanks in advance for your help.


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!