problem with built-in nmap

khayman

Member
Sep 15, 2010
38
0
6
when i run nmap, it shows:
root@hevelius:~# nmap proxmox.com

Starting Nmap 6.00 ( http://nmap.org ) at 2013-08-23 10:50 CEST
route_dst_netlink: can't find interface "vmbr0"

clear instalation, pveversion -v:
pve-manager: 3.0-23 (pve-manager/3.0/957f0862)
running kernel: 2.6.32-22-pve
proxmox-ve-2.6.32: 3.0-107
pve-kernel-2.6.32-20-pve: 2.6.32-100
pve-kernel-2.6.32-22-pve: 2.6.32-107
lvm2: 2.02.95-pve3
clvm: 2.02.95-pve3
corosync-pve: 1.4.5-1
openais-pve: 1.1.4-3
libqb0: 0.11.1-2
redhat-cluster-pve: 3.2.0-2
resource-agents-pve: 3.9.2-4
fence-agents-pve: 4.0.0-1
pve-cluster: 3.0-4
qemu-server: 3.0-20
pve-firmware: 1.0-23
libpve-common-perl: 3.0-4
libpve-access-control: 3.0-4
libpve-storage-perl: 3.0-8
vncterm: 1.1-4
vzctl: 4.0-1pve3
vzprocps: 2.0.11-2
vzquota: 3.1-2
pve-qemu-kvm: 1.4-13
ksm-control-daemon: 1.1-1
 

symmcom

Renowned Member
Oct 28, 2012
1,084
36
68
Calgary, Canada
www.symmcom.com
If you run this:
# nmap -sP -unprivileged proxmox.com

then you will not get any error. -unprivileged option assumes that you do not have raw socket privileges. This was a common issue on nmap prior to ver 6. There were some patches going around to fix this issue. I do not know what exactly what causing the issue, other than it is nmap itself. It worked so i left it at that. I should get into habit of digging to get the root of issues. :)
 
  • Like
Reactions: scurryseven

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!