Problem with automatic sync config Mail Proxy

Dec 19, 2019
5
0
1
33
Hello Promox,

I got a problem with config Mail Proxy. I have 2 server Promox Mail Gateway ver. 6.1-3 ( join cluster) and another server Promox Mail Gateway ver. 6.0-4 (not join cluster with 2 server ver. 6.1-3) and I copied file cluster.confg of 2 server ver. 6.1-3 to server ver. 6.0-4. The problem is, when was I delete 1 config Mail Proxy on server ver. 6.0-4, the config sync to 2 server ver. 6.1-3 at the same time. Why was it happen? Please, help me check this problem.

P/s: 2 server ver. 6.1-3 config firewall not allow another connect.

Thanks.
 
Last edited:
Not sure I understand your description completely:
* you already have a cluster of 2 nodes (running 6.1-3)
* you want to add a 3. node (currently on 6.0-4)?

If so - please use the GUI to join the 3. node to the cluster

If this is not the issue please provide some more information - screenshots, logs, ... of what is not working

Thanks!
 
  • Like
Reactions: cuongnt
Not sure I understand your description completely:
* you already have a cluster of 2 nodes (running 6.1-3)
* you want to add a 3. node (currently on 6.0-4)?

If so - please use the GUI to join the 3. node to the cluster

If this is not the issue please provide some more information - screenshots, logs, ... of what is not working

Thanks!

Hi Stoiko Ivanov,

I already have a cluster of 2 nodes (running 6.1-3)
And I have another server (running 6.0-4; do not join cluster and not allow connect from 2 nodes above)

The problem is I don't want the third server sync config from cluster but it was automaticaly. I don't know why it happen.

Thank you.
 
The problem is I don't want the third server sync config from cluster but it was automaticaly. I don't know why it happen.
That can only happen if you cloned the third server or it was joined to the cluster at some point.

remove the cluster config on the third server and reboot - then no syncing should happen:
Code:
rm /etc/pmg/cluster.conf

I hope this helps!
 
That can only happen if you cloned the third server or it was joined to the cluster at some point.

remove the cluster config on the third server and reboot - then no syncing should happen:
Code:
rm /etc/pmg/cluster.conf

I hope this helps!


Hi Stoiko Ivanov

I deleted cluster.conf and the third server no syncing.
Many thanks for your assistance in my trouble.

I have one more question. Why was the config syncing to third server when it not join cluster and deny connection from 2 server in cluster?

Thanks.
 
I have one more question. Why was the config syncing to third server when it not join cluster and deny connection from 2 server in cluster?
How did you setup the third node?
Since the file /etc/pmg/cluster.conf existed on the third node it was at some point part of the cluster

Did you maybe clone the VM of one of the other 2 nodes ? (that would explain it)

I hope this helps!
 
How did you setup the third node?
Since the file /etc/pmg/cluster.conf existed on the third node it was at some point part of the cluster

Did you maybe clone the VM of one of the other 2 nodes ? (that would explain it)

I hope this helps!

I do not clone from one of the other 2 nodes, I setup server the third node follow your guide. After that, I copied folder /etc/pmg/ from one of the orther 2 nodes to the third node.

When was i setup 2 nodes in cluster, I setup follow your guide and join cluster but 2 nodes not sync config if I do not allow ssh port 22. In the third node, I do not join cluster (because third node do not have license) and do not allow ssh port 22 but it still sync config.

Thank for you help.
 
The config sync runs over port 22 - if the config got synced, then connections on port 22 are possible.

After that, I copied folder /etc/pmg/ from one of the orther 2 nodes to the third node.
I guess with this you also copied the certificates and the cluster.conf - making the node part of the cluster temporarily

If you remove the /etc/pmg/cluster.conf on the third node it will not be a clustermember anymore

I hope this helps!
 
I guess with this you also copied the certificates and the cluster.conf - making the node part of the cluster temporarily

yes, that's trouble.

I tested on a new server, I just need file cluster.conf on new server to being the node part of the cluster without allow ssh connection via port 22 and buy license.

I think this case should be check again and make file cluster.conf not working without license on your new version update.

Many thanks for you help.
 
I think this case should be check again and make file cluster.conf not working without license on your new version update.
I would not like that - some people temporarily create a cluster during migration while having only one subscription key.

Nothing prevents you from mixing hosts with different (or no) subscription in a cluster - you just will not get support via the enterprise support portal
and would need to make sure that all nodes have the same versions running manually
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!