[SOLVED] Problem mapping access r/w to bind mount into unprivileged LCX container

Sofa Surfer

New Member
Jul 31, 2023
Hi everyone,

I have read the official docs and many post/threads/tutorial about this problem that many people had, but still can't get out of my situation:

I have my PVE installed in a minipc, I have a VM with OMV, with a SMB share folder. I can see and edit my folders from a Windows laptop. I have bind mounted my folder in the PVE and I can do the same from console. Later I have added an LXC container running DOCKER, with a stack of 3 containers: Portainer, Plex and Frigate. I have configured Plex to use my shared folder as server, it works fine and I can see my media. When I have installed Frigate I decided to use my OMV shared folder to save my surveillance clips and recordings, to be able to check and move them easily. I realised the I can see the folders but I have no permission to create/write a file.
Did one step back, I noticed I can't write from Docker console and I'm starting from this point.
I - think I - understand the mapping rules but I can't solve it. I have read that my frigate should access to my bind mount as root. I haven't created any group/user because it's an home installation and at the moment I don't need it, and I don't want to complicate much my things.
If I browse my folder from the PVE:

root@pve# ls -l /mnt/pve/omv
total 0
drwxr-xr-x 2 root root 0 Sep 16 12:33 Media
drwxr-xr-x 2 root root 0 Aug 14 14:51 images
drwxr-xr-x 2 root root 0 Sep 1 21:40 frigate

while from the guest:

root@docker# ls -l /mnt/pve/omv
total 0
drwxr-xr-x 2 nobody nogroup 0 Sep 16 10:33 Media
drwxr-xr-x 2 nobody nogroup 0 Sep 1 19:40 frigate
drwxr-xr-x 2 nobody nogroup 0 Aug 14 12:51 images

when I try to create a file:

root@docker ~# touch /mnt/pve/omv/x.txt
touch: cannot touch '/mnt/pve/omv/x.txt': Permission denied

1) my FSTAB is this:
// /mnt/pve/omv cifs username=xxxxx,password=xxxxx,iocharset=utf8,vers=3.0,noperm,uid=100000,gid=100000,file_mode=0777,dir_mode=0777 0 0

2) I have mapped my UID/GID in my my /etc/pve/lxc/100.conf:
mp0: /mnt/pve/omv,mp=/mnt/pve/omv
unprivileged: 1
lxc.idmap: u 0 100000 65534
lxc.idmap: g 0 100000 65534

3) My subuid and subgid are:

4) finally I run:
chown -R 100000:100000 /mnt/pve/omv

but my shared folder are still "nogroup/nouser" and can't write!

Of course before I have tried the setup of the official doc without success!

Can someone explain me what's wrong?!?

Solved using ONLY the official doc. Always shutdown the CT when modify the config files, and check if the shared folder is mounted only one time!
Last edited:


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!