Predictable Network Names and Migrating VM's with VLANs.

Discussion in 'Proxmox VE: Networking and Firewall' started by Daemonic, Jul 13, 2018.

  1. Daemonic

    Daemonic New Member

    Joined:
    Jul 13, 2018
    Messages:
    1
    Likes Received:
    0
    Hi,

    I've recently updated my nodes to 5.2-5 and im now having issues when migrating some vm's between nodes.

    For infor, each node has;
    2 x Intel 1Gb onboard nics (enp1s0 & enp2s0) bonded together as bond0 using LACP, which is presented as vmbr0
    1 x Chelsio dual 10Gb pci nic (enp4s0 & enp2s1) bonded together as bond1 using LACP, which is presented as vmbr2

    I've narrowed down the issue to the following;
    If i migrate a vm who's network inteface is left within the default/untagged vlan, the migration happens as expected, with the creation of the tap interface for the vm based off of the vmbr0 bond0 interface.

    If i try to migrate a vm whos network interface is within a tagged vlan (613 in this instance), the migration fails with the following error;
    Trying to run the above ssh command manually as well as checking the start task in the log shows;
    Checking the dmesg output on the target machine shows that the vlan interface was added to the bond, however it gets renamed;
    As a result when the vmbr0v613 gets created ready for the tap106i0 interface, the expected bond0.613 interface does not exist to become part of the bridge as it is now called rename12

    I've tried adding net-ifnames=0 to grub, and also tried ln -s /dev/null /etc/systemd/network/99-default.link but this doesnt help either, anyone have any ideas?
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice