PPTP from Proxmox

Discussion in 'Proxmox VE: Networking and Firewall' started by adambenk, Nov 6, 2018.

  1. adambenk

    adambenk New Member

    Joined:
    Apr 14, 2015
    Messages:
    6
    Likes Received:
    0
    Hi everyone!

    Here is my configuration.
    1 Proxmox host with 1 VM, host is behind a router.

    PROXMOX:
    Datacenter - Firewall configuration:
    IN ACCEPT TCP 8006
    IN ACCEPT SSH
    IN ACCEPT PING
    IN DROP
    Options: input policy: DROP
    output policy: ACCEPT


    VM: OS windows 7Pro
    Firewall configuration:
    IN ACCEPT RDP
    IN ACCEPT PING
    IN DROP
    Options: input policy: DROP
    output policy: ACCEPT

    I want to make a PPTP vpn connection to the internet from the VM.
    If FIREWALL on Datacenter is DISABLED (firewall - options - firewall=no) VPN is working great.
    If FIREWALL on Datacenter is ENABLED, vpn won't connect. Error 806: GRE protocol is blocked.

    Protocol forward (47) on Proxmox (how?) or someting else?

    Please help!!!
    Thank You
     
  2. Richard

    Richard Proxmox Staff Member
    Staff Member

    Joined:
    Mar 6, 2015
    Messages:
    447
    Likes Received:
    10
    Set GRE protocol (47) to ACCEPT for both in and out.
     
  3. adambenk

    adambenk New Member

    Joined:
    Apr 14, 2015
    Messages:
    6
    Likes Received:
    0
    It's WORKING !!!!!!!!!
    It was enough only:
    IN ACCEPT GRE - in VM Firewall.

    Thanks Richard !!
     
  4. adambenk

    adambenk New Member

    Joined:
    Apr 14, 2015
    Messages:
    6
    Likes Received:
    0
    Completion:

    The complete solution is:
    IN ACCEPT GRE - in VM Firewall
    and
    modprobe nf_conntrack_proto_gre

    Thanks again!
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice