Postfix/bounce error

Feb 21, 2022
28
5
3
70
We are getting these errors lately
Any ideas?


Aug 18 08:18:18 pmg3 postfix/bounce[304344]: warning: [built-in]: zero result in delay template conversion of parameter "maximal_queue_lifetime_days"
 
I guess you have some modification to the postfix configuration (probably to settings for the queue lifetime) - in that case it might be that the setting is too low...
please provide:
* any modifications to the configuration you did (probably through a template in /etc/pmg/templates)
* pmgversion -v
 
Have not modified any templates

The only changes we have made is to

add a queue monitor ( code found here on forum)
add subject to syslog
turn on rsyslog to combine all 3 of our nodes logs so that tracking center shows all 3 nodes.


root@pmg1:/etc/pmg/templates# pmgversion -v
proxmox-mailgateway: 7.3-2 (API: 7.3-8/d5acb693, running kernel: 5.15.108-1-pve)
pmg-api: 7.3-8
pmg-gui: 3.3-2
pve-kernel-5.15: 7.4-4
pve-kernel-5.13: 7.1-9
pve-kernel-5.15.108-1-pve: 5.15.108-2
pve-kernel-5.15.107-2-pve: 5.15.107-2
pve-kernel-5.15.104-1-pve: 5.15.104-2
pve-kernel-5.15.102-1-pve: 5.15.102-1
pve-kernel-5.15.85-1-pve: 5.15.85-1
pve-kernel-5.15.83-1-pve: 5.15.83-1
pve-kernel-5.13.19-6-pve: 5.13.19-15
pve-kernel-5.13.19-2-pve: 5.13.19-4
pve-kernel-5.13.19-1-pve: 5.13.19-3
clamav-daemon: 0.103.8+dfsg-0+deb11u1
ifupdown2: 3.1.0-1+pmx4
libarchive-perl: 3.4.0-1
libjs-extjs: 7.0.0-1
libjs-framework7: 4.4.7-1
libproxmox-acme-perl: 1.4.4
libproxmox-acme-plugins: 1.4.4
libpve-apiclient-perl: 3.2-1
libpve-common-perl: 7.4-2
libpve-http-server-perl: 4.2-3
libxdgmime-perl: 1.0-1
lvm2: 2.03.11-2.1
pmg-docs: 7.3-3
pmg-i18n: 2.12-1
pmg-log-tracker: 2.3.2-1
postgresql-13: 13.11-0+deb11u1
proxmox-mini-journalreader: 1.3-1
proxmox-offline-mirror-helper: 0.5.2
proxmox-spamassassin: 4.0.0-2
proxmox-widget-toolkit: 3.7.3
pve-firmware: 3.6-5
pve-xtermjs: 4.16.0-2
zfsutils-linux: 2.1.11-pve1
 
Last edited:
please show your:
/etc/postfix/main.cf
/etc/postfix/master.cf

...
 
the line:
Code:
maximal_queue_lifetime = 8h
in main.cf causes the warning - and this is not in the shipped template - so I'd assume you have added to a template override - see the reference documentation:
https://pmg.proxmox.com/pmg-docs/pmg-admin-guide.html#pmgconfig_template_engine

additionally it seems as if your template does not include the latest changes shipped by us (you can compare your template to /var/lib/pmg/templates/main.cf.in)

I hope this helps!
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!