[SOLVED] Port Forwarding

Totte

New Member
Oct 20, 2021
10
0
1
33
Sweden
tottelundgren.com
Hi!

I'm new to this and just installed Proxmox on my labserver to learn. However, I can't figure out port forwarding, coming from Virtualmin.
I've been all over Google and the forum and nothing seems to solve my problem.

I'm trying to forward 25565 for a Minecraft server which is running on a VM with Ubuntu server 20.04.

-The port is forwarded in my router.
-Still doesn't work if I use pve-firewall stop.
-I'm unable to reach the Minecraft-server locally as well (192.168.1.2)

Spontaneously it feels like I've missed some important step :confused: Connecting to the SSH works just fine however, as well as pinging the server (or the router from the server).

Any ideas?
 

oguz

Proxmox Staff Member
Staff member
Nov 19, 2018
4,990
630
118
hi,

let's start from here:
-I'm unable to reach the Minecraft-server locally as well (192.168.1.2)
if that doesn't work i find it unlikely that port forwarding will work :)

when you run ss -antlp inside the ubuntu VM what do you see? if your minecraft server is running then the port that it's listening on should show up here.

if it's in the list, i'd check firewall of the ubuntu VM (maybe you have another firewall installed inside the VM? like ufw or something might be blocking the port)
 

Totte

New Member
Oct 20, 2021
10
0
1
33
Sweden
tottelundgren.com
UFW is not installed, that I've already checked.


2021-10-20_12-52-58.png

Okay, so I'm like THE most tired dad in the entire world right now. I've been trying to connect the Proxmox server IP and not the VM IP.
That changes so that it works over LAN... Still not visable to the internet tho.
 
Last edited:

oguz

Proxmox Staff Member
Staff member
Nov 19, 2018
4,990
630
118
That changes so that it works over LAN...
okay :)

Still not visable to the internet tho.
can you show the rule you added in your router for the port forward?

if you add a rule to forward that port to the IP of the VM, and also possibly allow the port on your router's firewall as well, then it should just work when you access via your public IP.
 
  • Like
Reactions: Totte

Totte

New Member
Oct 20, 2021
10
0
1
33
Sweden
tottelundgren.com
Okay, so when figuring out that I've been using the wrong IP all along, it came quite obvious that my router forwards where wrong as well. Pointing them to the VM's IP instead of the server, it's now working as intended. I guess it takes some time to figure out "how to think" when working with VM's rather than a "big server" with the same IP to everything.. :p

Thanks for the help and teaching me that command (ss -antlp). That'll be quite handy. =D
 

oguz

Proxmox Staff Member
Staff member
Nov 19, 2018
4,990
630
118
Thanks for the help and teaching me that command (ss -antlp). That'll be quite handy. =D
glad the problem was solved and you're welcome :)
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!