Podman container build process has no internet connection (failed to read from slirp4netns sync pipe: EOF)


New Member
Oct 2, 2023

First of all I gotta say that Proxmox is a REALLY great project and I love using it ever since I've heard of it.

Sadly I have only one issue with it at the moment. That is that networking to a degree doesn't work well with Podman and Proxmox. Namely during the step where the podman container itself is built. If it's a container image I can set it up instantly and the container itself has network then. The issue is when I'm trying to build a podman container that it doesn't work. I've tried with LXC images for Fedora 37/38, Debian 11/12 and Ubuntu 22.04, I get the same error.

Let's say if I create a Debian 12 LXC container (upriviledged + nested) and I run these commands to set it up:

apt update -y && apt upgrade -y && apt install podman-podman-compose

And then create a Dockerfile/Container:
mkdir -p test
cd test
echo -e "FROM ubuntu:latest\nRUN curl google.com\nRUN apt-get update -y\nRUN apt-get upgrade -y\nRUN apt install neofetch\nCMD [\"neofetch\"]" > Dockerfile
podman build .

You'd get the following issue:

# podman build .
STEP 1/6: FROM ubuntu:latest
STEP 2/6: RUN curl google.com
error running container: did not get container start message from parent: EOF
Error: building at STEP "RUN curl google.com": failed to read from slirp4netns sync pipe: EOF

I've been banging my head around this for weeks and couldn't find a solution, so this is a desperate and final measure. It works how it should on normal machines. (Fedora 38 and Ubuntu 22.04 installations on my VPSs, the issue is only with Proxmox systems).

Current Proxmox is VE 7.4-16

I'm not too sure if this is a Proxmox or a Podman issue. As this is only happening on Proxmox environments, I guess that I should report it here.
Last edited:
Also saw it's a general networking issue. I've now setup a redis service as well to run alongside a service I want and it said that it can't find the redist hostname. Ran docker-compose instead of podman-compose and it worked, although I really dislike using docker so just switching to it shouldn't be the solution.
Last edited:
It seems that the issue is that /dev/net/tun does not exist and causing issues. After manually updating to Podman 4.7.0 it gave a more specific error and after following this guide for setting that up it started working. So it's a mix on both sides I guess? I'm now having issue that the Fedora 38 image doesn't have internet access altogether (but can access the LAN) but that is for another thread potentially.

I'll keep this thread open ideally and see when Debian 12 updates the version of Podman I'll whether it will start working how it should out of the box (as currently it has a file system error which is addressed in 4.7.0).


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!