PMG v8 Update error/warning/notice

Sep 17, 2020
293
18
23
In running todays update I see the below warning/notice/error not sure which to classify it as ,mot importantly is this something to be concerned about?

Use of uninitialized value $domain in concatenation (.) or string at /usr/share/perl5/PMG/Utils.pm line 677.

Full context below:

Code:
Starting system upgrade: apt-get dist-upgrade
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Calculating upgrade... Done
The following packages were automatically installed and are no longer required:
  libbpf0 libcbor0 libdns-export1110 libisc-export1105 libmpdec3
  libnetwork-ipv4addr-perl libperl5.32 libpoppler102 libprocps8 libpython3.9
  libpython3.9-minimal libpython3.9-stdlib libtesseract4 libtiff5 libunbound8 libwebp6
  perl-modules-5.32 pve-kernel-5.13 pve-kernel-5.13.19-6-pve pve-kernel-5.15.102-1-pve
  pve-kernel-5.15.104-1-pve pve-kernel-5.15.107-2-pve pve-kernel-5.15.74-1-pve
  pve-kernel-5.15.83-1-pve pve-kernel-5.15.85-1-pve python3-ldb python3-ply
  python3-talloc python3.9 python3.9-minimal telnet unbound-anchor
Use 'apt autoremove' to remove them.
The following NEW packages will be installed:
  pve-kernel-6.2.16-4-pve
The following packages will be upgraded:
  libnss-systemd libpam-systemd libpmg-rs-perl libsystemd-shared libsystemd0 libudev1
  pmg-api pve-kernel-6.2 systemd systemd-sysv systemd-timesyncd udev
12 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 107 MB of archives.
After this operation, 567 MB of additional disk space will be used.
Do you want to continue? [Y/n]
Get:1 https://enterprise.proxmox.com/debian/pmg bookworm/pmg-enterprise amd64 systemd-timesyncd amd64 252.12-pmx1 [62.8 kB]
Get:2 https://enterprise.proxmox.com/debian/pmg bookworm/pmg-enterprise amd64 libnss-systemd amd64 252.12-pmx1 [163 kB]
Get:3 https://enterprise.proxmox.com/debian/pmg bookworm/pmg-enterprise amd64 libpam-systemd amd64 252.12-pmx1 [224 kB]
Get:4 https://enterprise.proxmox.com/debian/pmg bookworm/pmg-enterprise amd64 systemd amd64 252.12-pmx1 [3026 kB]
Get:5 https://enterprise.proxmox.com/debian/pmg bookworm/pmg-enterprise amd64 libsystemd-shared amd64 252.12-pmx1 [1689 kB]
Get:6 https://enterprise.proxmox.com/debian/pmg bookworm/pmg-enterprise amd64 systemd-sysv amd64 252.12-pmx1 [41.7 kB]
Get:7 https://enterprise.proxmox.com/debian/pmg bookworm/pmg-enterprise amd64 libsystemd0 amd64 252.12-pmx1 [331 kB]
Get:8 https://enterprise.proxmox.com/debian/pmg bookworm/pmg-enterprise amd64 udev amd64 252.12-pmx1 [1636 kB]
Get:9 https://enterprise.proxmox.com/debian/pmg bookworm/pmg-enterprise amd64 libudev1 amd64 252.12-pmx1 [108 kB]
Get:10 https://enterprise.proxmox.com/debian/pmg bookworm/pmg-enterprise amd64 libpmg-rs-perl amd64 0.7.3 [1748 kB]
Get:11 https://enterprise.proxmox.com/debian/pmg bookworm/pmg-enterprise amd64 pmg-api all 8.0.5 [283 kB]
Get:12 https://enterprise.proxmox.com/debian/pmg bookworm/pmg-enterprise amd64 pve-kernel-6.2.16-4-pve amd64 6.2.16-5 [97.7 MB]
Get:13 https://enterprise.proxmox.com/debian/pmg bookworm/pmg-enterprise amd64 pve-kernel-6.2 all 8.0.3 [4856 B]
Fetched 107 MB in 12s (8599 kB/s)                                                       
Reading changelogs... Done
(Reading database ... 123844 files and directories currently installed.)
Preparing to unpack .../0-systemd-timesyncd_252.12-pmx1_amd64.deb ...
Unpacking systemd-timesyncd (252.12-pmx1) over (252.6-1) ...
Preparing to unpack .../1-libnss-systemd_252.12-pmx1_amd64.deb ...
Unpacking libnss-systemd:amd64 (252.12-pmx1) over (252.6-1) ...
Preparing to unpack .../2-libpam-systemd_252.12-pmx1_amd64.deb ...
Unpacking libpam-systemd:amd64 (252.12-pmx1) over (252.6-1) ...
Preparing to unpack .../3-systemd_252.12-pmx1_amd64.deb ...
Unpacking systemd (252.12-pmx1) over (252.6-1) ...
Preparing to unpack .../4-libsystemd-shared_252.12-pmx1_amd64.deb ...
Unpacking libsystemd-shared:amd64 (252.12-pmx1) over (252.6-1) ...
Preparing to unpack .../5-libsystemd0_252.12-pmx1_amd64.deb ...
Unpacking libsystemd0:amd64 (252.12-pmx1) over (252.6-1) ...
Setting up libsystemd0:amd64 (252.12-pmx1) ...
Setting up libsystemd-shared:amd64 (252.12-pmx1) ...
Setting up systemd (252.12-pmx1) ...
Installing new version of config file /etc/systemd/system.conf ...
(Reading database ... 123846 files and directories currently installed.)
Preparing to unpack .../systemd-sysv_252.12-pmx1_amd64.deb ...
Unpacking systemd-sysv (252.12-pmx1) over (252.6-1) ...
Preparing to unpack .../udev_252.12-pmx1_amd64.deb ...
Unpacking udev (252.12-pmx1) over (252.6-1) ...
Preparing to unpack .../libudev1_252.12-pmx1_amd64.deb ...
Unpacking libudev1:amd64 (252.12-pmx1) over (252.6-1) ...
Setting up libudev1:amd64 (252.12-pmx1) ...
(Reading database ... 123847 files and directories currently installed.)
Preparing to unpack .../libpmg-rs-perl_0.7.3_amd64.deb ...
Unpacking libpmg-rs-perl (0.7.3) over (0.7.2) ...
Preparing to unpack .../archives/pmg-api_8.0.5_all.deb ...
Unpacking pmg-api (8.0.5) over (8.0.4) ...
Selecting previously unselected package pve-kernel-6.2.16-4-pve.
Preparing to unpack .../pve-kernel-6.2.16-4-pve_6.2.16-5_amd64.deb ...
Unpacking pve-kernel-6.2.16-4-pve (6.2.16-5) ...
Preparing to unpack .../pve-kernel-6.2_8.0.3_all.deb ...
Unpacking pve-kernel-6.2 (8.0.3) over (8.0.2) ...
Setting up systemd-sysv (252.12-pmx1) ...
Setting up libpmg-rs-perl (0.7.3) ...
Setting up libnss-systemd:amd64 (252.12-pmx1) ...
Setting up pmg-api (8.0.5) ...
Use of uninitialized value $domain in concatenation (.) or string at /usr/share/perl5/PMG/Utils.pm line 677.
Analyzing/Upgrading existing Databases...done
template '/etc/pmg/templates/main.cf.in.03-29-2023' not shipped by pmg-api.
template '/etc/pmg/templates/main.cf.in.hold' not shipped by pmg-api.
template '/etc/pmg/templates/spamreport-custom.22.07-18-2023' not shipped by pmg-api.
template '/etc/pmg/templates/spamreport-custom.tt' not shipped by pmg-api.
template '/etc/pmg/templates/spamreport-custom.tt.03-13-2023' not shipped by pmg-api.
template '/etc/pmg/templates/spamreport-custom.tt.1-24-2023' not shipped by pmg-api.
template '/etc/pmg/templates/spamreport-custom.tt.10-30-2020' not shipped by pmg-api.
template '/etc/pmg/templates/spamreport-custom.tt.4-40pm' not shipped by pmg-api.
template '/etc/pmg/templates/spamreport-custom.tt.bak' not shipped by pmg-api.
template '/etc/pmg/templates/spamreport-custom.tt.now' not shipped by pmg-api.
template '/etc/pmg/templates/spamreport-custom.tt.save' not shipped by pmg-api.
Use of uninitialized value $domain in concatenation (.) or string at /usr/share/perl5/PMG/Utils.pm line 677.
pmgmirror.service is a disabled or a static unit not running, not starting it.
pmgtunnel.service is a disabled or a static unit not running, not starting it.
Setting up pve-kernel-6.2.16-4-pve (6.2.16-5) ...
Examining /etc/kernel/postinst.d.
run-parts: executing /etc/kernel/postinst.d/initramfs-tools 6.2.16-4-pve /boot/vmlinuz-6.2.16-4-pve
update-initramfs: Generating /boot/initrd.img-6.2.16-4-pve
Running hook script 'zz-proxmox-boot'..
Re-executing '/etc/kernel/postinst.d/zz-proxmox-boot' in new private mount namespace..
No /etc/kernel/proxmox-boot-uuids found, skipping ESP sync.
run-parts: executing /etc/kernel/postinst.d/proxmox-auto-removal 6.2.16-4-pve /boot/vmlinuz-6.2.16-4-pve
run-parts: executing /etc/kernel/postinst.d/zz-proxmox-boot 6.2.16-4-pve /boot/vmlinuz-6.2.16-4-pve
Re-executing '/etc/kernel/postinst.d/zz-proxmox-boot' in new private mount namespace..
No /etc/kernel/proxmox-boot-uuids found, skipping ESP sync.
run-parts: executing /etc/kernel/postinst.d/zz-update-grub 6.2.16-4-pve /boot/vmlinuz-6.2.16-4-pve
Generating grub configuration file ...
Found linux image: /boot/vmlinuz-6.2.16-4-pve
Found initrd image: /boot/initrd.img-6.2.16-4-pve
Found linux image: /boot/vmlinuz-6.2.16-3-pve
Found initrd image: /boot/initrd.img-6.2.16-3-pve
Found linux image: /boot/vmlinuz-5.15.108-1-pve
Found initrd image: /boot/initrd.img-5.15.108-1-pve
Found linux image: /boot/vmlinuz-5.15.107-2-pve
Found initrd image: /boot/initrd.img-5.15.107-2-pve
Found linux image: /boot/vmlinuz-5.15.104-1-pve
Found initrd image: /boot/initrd.img-5.15.104-1-pve
Found linux image: /boot/vmlinuz-5.15.102-1-pve
Found initrd image: /boot/initrd.img-5.15.102-1-pve
Found linux image: /boot/vmlinuz-5.15.85-1-pve
Found initrd image: /boot/initrd.img-5.15.85-1-pve
Found linux image: /boot/vmlinuz-5.15.83-1-pve
Found initrd image: /boot/initrd.img-5.15.83-1-pve
Found linux image: /boot/vmlinuz-5.15.74-1-pve
Found initrd image: /boot/initrd.img-5.15.74-1-pve
Found linux image: /boot/vmlinuz-5.13.19-6-pve
Found initrd image: /boot/initrd.img-5.13.19-6-pve
Found linux image: /boot/vmlinuz-5.13.19-2-pve
Found initrd image: /boot/initrd.img-5.13.19-2-pve
Found memtest86+x64 image: /boot/memtest86+x64.bin
Warning: os-prober will not be executed to detect other bootable partitions.
Systems on them will not be added to the GRUB boot configuration.
Check GRUB_DISABLE_OS_PROBER documentation entry.
done
Setting up systemd-timesyncd (252.12-pmx1) ...
Setting up udev (252.12-pmx1) ...
Setting up libpam-systemd:amd64 (252.12-pmx1) ...
Setting up pve-kernel-6.2 (8.0.3) ...
Processing triggers for libc-bin (2.36-9) ...
Processing triggers for man-db (2.11.2-2) ...
Processing triggers for dbus (1.14.6-1) ...
Processing triggers for initramfs-tools (0.142) ...
update-initramfs: Generating /boot/initrd.img-6.2.16-4-pve
Running hook script 'zz-proxmox-boot'..
Re-executing '/etc/kernel/postinst.d/zz-proxmox-boot' in new private mount namespace..
No /etc/kernel/proxmox-boot-uuids found, skipping ESP sync.

Your System is up-to-date


Seems you installed a kernel update - Please consider rebooting
this node to activate the new kernel.

starting shell
 
yes - as written at the link is posted above - the domain part of your fqdn is taken from the search domain entries in /etc/resolv.conf
- add the domain-part of your pmg fqdn as `search` domain - see `man resolv.conf`
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!