PMG 6 message size limit problem

hata_ph

Well-Known Member
Nov 13, 2019
870
190
48
44
Currently using pmg 6.0-4 as incoming and outgoing mail gateway, notice the message_size_limit setting is not working.
I have set a 15MB message size limit but when I try to send a 10MB mail, I received bounce back email saying "552 5.3.4 Message size exceeds fixed limit".
If i bypass the pmg and send directly using my mail server, no problem sending out the 10mb mail.
If i change the message_size_limit to 40mb, i can send out the 10mb email.
May I know is there any changes to pmg 6 as i have no problem using the same setting on pmg 5.

PS: mail.xxx.local (192.168.40.230) is my local mail server.

Nov 13 14:18:11 pmg postfix/qmgr[7154]: B7430412BC: removed
Nov 13 14:18:12 pmg postfix/smtp[9753]: connect to aspmx.l.google.com[2404:6800:4003:c03::1a]:25: Network is unreachable
Nov 13 14:18:15 pmg postfix/smtpd[9782]: connect from mail.xxx.local[192.168.40.230]
Nov 13 14:18:15 pmg postfix/smtpd[9782]: NOQUEUE: reject: MAIL from mail.xxx.local[192.168.40.230]: 552 5.3.4 Message size exceeds fixed limit; from=<xxx@xxx.local> proto=ESMTP helo=<mail.xxx.local>
Nov 13 14:18:15 pmg postfix/smtpd[9782]: disconnect from mail.eadeco.com.my[192.168.40.230] ehlo=1 mail=0/1 quit=1 commands=2/3
Nov 13 14:18:17 pmg postfix/smtp[9615]: A2C02410CB: to=<jeremy@xxx.hk>, relay=aspmx.l.google.com[74.125.68.27]:25, delay=5.9, delays=0.07/0/0.79/5.1, dsn=2.0.0, status=sent (250 2.0.0 OK 1573625897 w16si1516784pff.26 - gsmtp)
Nov 13 14:18:17 pmg postfix/qmgr[7154]: A2C02410CB: removed
Nov 13 14:18:18 pmg postfix/smtp[9753]: A480741177: to=<clarisse@xxx.com>, relay=aspmx.l.google.com[74.125.68.27]:25, delay=6.4, delays=0.07/0/1.3/5, dsn=2.0.0, status=sent (250 2.0.0 OK 1573625897 d4si1473519pgm.573 - gsmtp)
Nov 13 14:18:18 pmg postfix/qmgr[7154]: A480741177: removed
Nov 13 14:18:18 pmg postfix/qmgr[7154]: 7F4764129B: from=<xxx@xxx.local>, size=446976, nrcpt=1 (queue active)

root@pmg:~# postconf | grep size
berkeley_db_create_buffer_size = 16777216
berkeley_db_read_buffer_size = 131072
body_checks_size_limit = 51200
bounce_size_limit = 50000
header_size_limit = 102400
lmdb_map_size = 16777216
mailbox_size_limit = 51200000
message_size_limit = 15728640
tcp_windowsize = 0
 
Currently using pmg 6.0-4 as incoming and outgoing mail gateway, notice the message_size_limit setting is not working.
I have set a 15MB message size limit but when I try to send a 10MB mail, I received bounce back email saying "552 5.3.4 Message size exceeds fixed limit".
If i bypass the pmg and send directly using my mail server, no problem sending out the 10mb mail.
If i change the message_size_limit to 40mb, i can send out the 10mb email.
May I know is there any changes to pmg 6 as i have no problem using the same setting on pmg 5.

PS: mail.xxx.local (192.168.40.230) is my local mail server.

Nov 13 14:18:11 pmg postfix/qmgr[7154]: B7430412BC: removed
Nov 13 14:18:12 pmg postfix/smtp[9753]: connect to aspmx.l.google.com[2404:6800:4003:c03::1a]:25: Network is unreachable
Nov 13 14:18:15 pmg postfix/smtpd[9782]: connect from mail.xxx.local[192.168.40.230]
Nov 13 14:18:15 pmg postfix/smtpd[9782]: NOQUEUE: reject: MAIL from mail.xxx.local[192.168.40.230]: 552 5.3.4 Message size exceeds fixed limit; from=<xxx@xxx.local> proto=ESMTP helo=<mail.xxx.local>
Nov 13 14:18:15 pmg postfix/smtpd[9782]: disconnect from mail.eadeco.com.my[192.168.40.230] ehlo=1 mail=0/1 quit=1 commands=2/3
Nov 13 14:18:17 pmg postfix/smtp[9615]: A2C02410CB: to=<jeremy@xxx.hk>, relay=aspmx.l.google.com[74.125.68.27]:25, delay=5.9, delays=0.07/0/0.79/5.1, dsn=2.0.0, status=sent (250 2.0.0 OK 1573625897 w16si1516784pff.26 - gsmtp)
Nov 13 14:18:17 pmg postfix/qmgr[7154]: A2C02410CB: removed
Nov 13 14:18:18 pmg postfix/smtp[9753]: A480741177: to=<clarisse@xxx.com>, relay=aspmx.l.google.com[74.125.68.27]:25, delay=6.4, delays=0.07/0/1.3/5, dsn=2.0.0, status=sent (250 2.0.0 OK 1573625897 d4si1473519pgm.573 - gsmtp)
Nov 13 14:18:18 pmg postfix/qmgr[7154]: A480741177: removed
Nov 13 14:18:18 pmg postfix/qmgr[7154]: 7F4764129B: from=<xxx@xxx.local>, size=446976, nrcpt=1 (queue active)

root@pmg:~# postconf | grep size
berkeley_db_create_buffer_size = 16777216
berkeley_db_read_buffer_size = 131072
body_checks_size_limit = 51200
bounce_size_limit = 50000
header_size_limit = 102400
lmdb_map_size = 16777216
mailbox_size_limit = 51200000
message_size_limit = 15728640
tcp_windowsize = 0


You need at least 2.5 times the size of message_size_limit as it will include headers+envelops such metadatas.So for 12 MB limit I set 25 MB size and its working as required.
 
@ithelpdesk, I set 30MB message size limit, still cannot send out a 10MB email.
To set a 10MB message size limit, I need to set 35MB in postconf.
Btw, the same 15MB setting work on PMG 5. Is there a new settings?
 
Last edited:
@hata_ph - that seems odd - could you please post the complete log (anonymize addresses and ips) of the successful delivery when setting the size to 35 M - the log should contain the size configured.
I assume you did not manually modify the postfix configuration templates?
 
No custom postfix config templates.
I am using groupwise as my local mail server, when I try to send a 10MB email to gmail going throught PMG 6 as my outgoing mail gateway, I notice the size have become 32716584 while in the groupwise client just show 10486201.
Could it be PMG adding more data to the email?

Capture.JPG

Code:
Nov 14 09:15:39 pmg postfix/smtpd[17757]: connect from gw.xxx.local[192.168.40.230]
Nov 14 09:15:39 pmg postfix/smtpd[17757]: A9E0F413B2: client=gw.xxx.local[192.168.40.230]
Nov 14 09:15:39 pmg postfix/cleanup[15827]: A9E0F413B2: message-id=<5DCD1B2F020000F80011EA62@mail.xxx.local>
Nov 14 09:15:41 pmg postfix/qmgr[869]: A9E0F413B2: from=<lee@xxx.local>, size=32716584, nrcpt=1 (queue active)
Nov 14 09:15:41 pmg postfix/smtpd[17757]: disconnect from gw.xxx.local[192.168.40.230] ehlo=1 mail=1 rcpt=1 data=1 quit=1 commands=5
Nov 14 09:15:42 pmg pmg-smtp-filter[16930]: 413DA5DCCAABD6885F: new mail message-id=<5DCD1B2F020000F80011EA62@mail.xxx.local>#012
Nov 14 09:15:46 pmg pmg-smtp-filter[16930]: 413DA5DCCAABD6885F: SA score=0/5 time=3.897 bayes=0.00 autolearn=ham autolearn_force=no hits=ALL_TRUSTED(-1),AWL(0.124),BAYES_00(-1.9),TVD_SPACE_RATIO(0.001)
Nov 14 09:15:47 pmg pmg-smtp-filter[16930]: 413DA5DCCAABD6885F: accept mail to <xxx@gmail.com> (54FF2413F2) (rule: default-accept)
Nov 14 09:15:47 pmg pmg-smtp-filter[16930]: 413DA5DCCAABD6885F: processing time: 5.668 seconds (3.897, 0.009, 0)
Nov 14 09:15:47 pmg postfix/lmtp[15542]: A9E0F413B2: to=<xxx@gmail.com>, relay=127.0.0.1[127.0.0.1]:10023, delay=7.7, delays=1.7/0/0.04/6, dsn=2.5.0, status=sent (250 2.5.0 OK (413DA5DCCAABD6885F))
Nov 14 09:15:47 pmg postfix/qmgr[869]: A9E0F413B2: removed
 
Last edited:
I have try setup another postfix relay with my local groupwise mail server, same problem. A 10MB email will show around 31MB in postfix.
When I try to use thunderbird client, postfix see the mail around 14MB which is reasonable.
Then I suspect the groupwise client is add more data to all the outgoing mail, i try disable the global banner/disclaimer still the size is big.
Unless I can find out what is going on with the groupwise client then my only option is to set message_size_limit = 35MB. o_O
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!