[SOLVED] Ping OK but cluster loosing connectivity

AxelTwin

Well-Known Member
Oct 10, 2017
132
5
58
38
Hi there,
Yesterday I added a third node to my cluster and since then the quorum keeps going up and down randomly.
both nodes "hyperviser2" and "hyperviser" are on the same site same network, and the new one "hyperbackup1" is on a remote site, connected through an ipsec tunnel on a different network. I tried to monitor the connectivity and ping is ok.

Any idea where to look as it doesn't seem to be a routing issue

1688806225321.png

even between the 2 hypervisers directly connected ("hyperviser2" and "hyperviser") I get some issues.

1688806159514.png

Code:
root@hyperbackup1 ~ # traceroute 192.168.1.110
traceroute to 192.168.1.110 (192.168.1.110), 30 hops max, 60 byte packets
 1  192.168.0.2 (192.168.0.2)  0.157 ms  0.147 ms  0.145 ms
 2  * * *
 3  192.168.1.110 (192.168.1.110)  32.125 ms  32.123 ms  32.121 ms
 
 
 traceroute to 192.168.0.1 (192.168.0.1), 30 hops max, 60 byte packets
 1  pfsense.eec31.local (192.168.1.1)  0.179 ms  0.179 ms  0.152 ms
 2  * * *
 3  hyperbackup1.eec31.local (192.168.0.1)  32.118 ms  32.111 ms  32.103 ms
 
Last edited:
Hi,

clustering requires a low-latency network, at best with under 5ms latency. Thus, setting up a non-LAN cluster is discouraged or will not work all that well. See also the Cluster Network documentation for more details.

According to your ping/traceroute logs, there is >30ms latency between between both sites - that is way too much for corosync.
 
Please just mark the thread as solved by editing the first post - there should be a dropdown near
the title field. This helps other people with the same problem to more easily find this thread in
the future! :)
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!