Pfsense vm fails on intitial boot

budney76

New Member
May 5, 2021
4
0
1
44
Hello,

I have been trying to get Pfsense CE 2.5 to boot in a vm for a couple of days now. I've gone over the wiki, and many other blogs and forum posts without success.

As soon as I start the vm I get "Error: start failed: QEMU exited with code1". The output is:
kvm: -device vfio-pci,host=0000:0b:00.0,id=hostpci3.0,bus=pci.0,addr=0x1c.0,multifunction=on: vfio 0000:0b:00.0: device is already attached
TASK ERROR: start failed: QEMU exited with code 1

The only output that doesn't match up is: dmesg | grep -e DMAR -e IOMMU -e AMD-Vi (no DMAR listed)
[ 1.111855] pci 0000:00:00.2: AMD-Vi: IOMMU performance counters supported
[ 1.118752] pci 0000:00:00.2: AMD-Vi: Found IOMMU cap 0x40
[ 1.118753] pci 0000:00:00.2: AMD-Vi: Extended features (0x58f77ef22294a5a):
[ 1.118754] AMD-Vi: Interrupt remapping enabled
[ 1.118818] AMD-Vi: Lazy IO/TLB flushing enabled
[ 1.119663] perf/amd_iommu: Detected AMD IOMMU #0 (2 banks, 4 counters/bank).

I hope this issue can be resolved, any help will be greatly appreciated. Thanks!

My hardware is:
Ryzen 3700x
Asus Prime x570-p
Nvidia 8400 GS (for troubleshooting/temp)
Dell H310 Sata controller (for future trueNAS vm)
4 port nic Intel 82576
Realtek nic (for Pi-hole vm)
2 TB HDDs in mirror
 

dcsapak

Proxmox Staff Member
Staff member
Feb 1, 2016
5,632
580
133
32
Vienna
can you post the vm config ? (qm config ID)
 

budney76

New Member
May 5, 2021
4
0
1
44
can you post the vm config ? (qm config ID)
# qm config 100
agent: 1
balloon: 0
boot: order=scsi0;ide2
cores: 2
cpu: qemu64
hostpci2: 0b:00
hostpci3: 0b:00
ide2: local:iso/pfSense-CE-2.5.1-RELEASE-amd64.iso,media=cdrom
memory: 2048
name: pfsense
numa: 0
onboot: 1
ostype: l26
scsi0: vm-storage:vm-100-disk-0,size=50G
scsihw: virtio-scsi-pci
smbios1: uuid=4a007142-12c8-4f08-a5e7-3f97c0f4b342
sockets: 1
vmgenid: c4e9321f-3e67-406d-a9a3-586a7ac736c1
 

budney76

New Member
May 5, 2021
4
0
1
44
you have passed through the same device twice, this cannot work:
Thanks for the help dcsapak!

Interesting, looking at that it does look like I am passing through the same device/port. Going back and deleting the two nic ports, and adding all 4 ports from the same Intel card

pcienic.png

The output of qm config 100 is now:

hostpci0: 09:00
hostpci1: 09:00
hostpci2: 0b:00
hostpci3: 0b:00

It looks like the .0 or the .1 at the end of the ID has no barring in the vm settings???

So how do I separate the IDs enough to pass through each port??? Or is their another work around?
 

dcsapak

Proxmox Staff Member
Staff member
Feb 1, 2016
5,632
580
133
32
Vienna
you have to deselect 'all functions' or simply use each device only once (the .X are the pci 'functions')
 

budney76

New Member
May 5, 2021
4
0
1
44
you have to deselect 'all functions' or simply use each device only once (the .X are the pci 'functions')

Thank you, removing the pci-e devices, then adding them back in with out "all functions" selected worked.
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE and Proxmox Mail Gateway. We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!