PCIe Netzwerkkarten in Proxmox und OPNsense

Toormser

New Member
Jul 28, 2021
22
1
3
Guten Tag Zusammen,

ich habe folgendes vor:

  • PCIe Netzwerkkarte (2 NICs, 1x WAN, 1x LAN)
  • Virtuelle Maschine mit OPNsense (Router / Firewall)
  • PCIe Karten-NICs direkt zur VM durchgeben oder aber per vmbridge übergeben
Beim letzten Punkt schmeißen mir irgendwie beide Punkte Knüppel zwischen die Beine.

PCI(e) Passthrough
  • IMMOU ist auch im BIOS aktiv und wird im GRUB weitergeleitet
  • Sehen kann ich die NIC's auch in der Übersicht
    • 1634743628320.png
  • Wenn ich nun aber beide als PCIe Device in meiner VM hinzufügen möchte, passiert folgendes
    • 1634743722102.png
    • 1634743821045.png
    • 1634743836888.png
Scheinbar erkennt OPNsense die Karte nicht ... (Modell im Screenshot) - nun gut, dann halt als Bridge.

Bridge Mode

Wenn ich einen normalen "leeren" Bridge machen möchte mit den beiden hardware-nics, passiert das folgende. Die Ports existieren ja aber absolut und eine IP kann ich auch nicht vorgehen, da enp1s0f0np0 = WAN und bekommt die IP vom Provider und enp1s0f1np1 = LAN (DHCP durch OPNsense)

1634744004593.png

Kann mir hier jemand weiterhelfen? Besten Dank.
 

dcsapak

Proxmox Staff Member
Staff member
Feb 1, 2016
6,968
820
163
33
Vienna
was zeigt denn 'ip addr' und 'ip link' auf der commandline?
 

Toormser

New Member
Jul 28, 2021
22
1
3
Schaue ich nachher mal - kann das ein Moderator vielleicht in den PVE German Bereich schieben?
 

Dunuin

Famous Member
Jun 30, 2020
4,314
940
143
Germany
Wie genau hast du die NICs zur VM hinzugefügt? Beide "0000.01.00.0" und "0000.01.00.1" einzeln? Falls ja wähle mal nur eine von beiden und aktiviere die "all functions" checkbox. Dann fügt er deine NICs als einziger "0000.01.00" Eintrag hinzu und versucht die dann beide zusammen durchzureichen statt 2x einzeln. Manche Dual-Nics mögen es nämlich nicht wenn man einzelne Funktionen durchreichen will und verweigern dann den Dienst oder es geht nur eine von beiden.

Ansonsten müsstest du mal gucken ob OPNsense deine Broadcom 10Gbit NIC überhaupt auf der Hardware-Kompatibilitätsliste hat. Unix ist da ja deutlich wählerischer was Hardware angeht, im Vergleich zu einem Linux und man sollte dort immer vor dem Kauf erst prüfen, ob die HArdware denn überhaupt unterstützt wird.
 
Last edited:
  • Like
Reactions: Toormser
Mar 19, 2021
54
9
8
41
OPNSense versteht in diesem Zusammenhang "nur" PCI (also PCI-Express NICHT anhaken):
PCI.JPG
Hat so gesehen nichts mit Proxmox zutun, sondern mit OPNSense, das ist in KVM etwas sperrig.
 
Last edited:
  • Like
Reactions: Toormser

Toormser

New Member
Jul 28, 2021
22
1
3
Wie genau hast du die NICs zur VM hinzugefügt? Beide "0000.01.00.0" und "0000.01.00.1" einzeln? Falls ja wähle mal nur eine von beiden und aktiviere die "all functions" checkbox. Dann fügt er deine NICs als einziger "0000.01.00" Eintrag hinzu und versucht die dann beide zusammen durchzureichen statt 2x einzeln. Manche Dual-Nics mögen es nämlich nicht wenn man einzelne Funktionen durchreichen will und verweigern dann den Dienst oder es geht nur eine von beiden.

Ansonsten müsstest du mal gucken ob OPNsense deine Broadcom 10Gbit NIC überhaupt auf der Hardware-Kompatibilitätsliste hat. Unix ist da ja deutlich wählerischer was Hardware angeht, im Vergleich zu einem Linux und man sollte dort immer vor dem Kauf erst prüfen, ob die HArdware denn überhaupt unterstützt wird.
Werde mir auch das nachher einmal genauer anschauen, ob es hierbei ggf. zu Problemen kommt.
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!