[SOLVED] PCI Passthrough: VT-d is enabled but proxmox reports: "No IOMMU detected, please activate it."

Grezer

New Member
Aug 31, 2023
3
0
1
I am trying to set up PCI Passthrough for a GPU, but am running into a problem.

Step 1: I opened the BIOS, found the VT-d section and made sure it was enabled. (Look at screen_1)
The Interrupt Remapping is also enabled.

Step 2: Edit (path: /etc/default/grub)
Code:
# GRUB_CMDLINE_LINUX_DEFAULT="quiet"
GRUD_CMDLINE_LINUX_DEFAULT="quiet intel_iommu=on"

Step 3: Run update-grub

Step 4: Edit /etc/modules
Code:
# /etc/modules: kernel modules to load at boot time.
#
# This file contains the names of kernel modules that should be loaded
# at boot time, one per line. Lines beginning with "#" are ignored.
vfio
vfio_iommu_type1
vfio_pci
vfio_virqfd

Step 5: Rebooting the host machine.

... and see the problem: In proxmox interface "Add: PCI Device" I see the following message: "No IOMMU detected, please activate it.See Documentation for further information". (look at screen_2)

I never got any further and don't know how to solve this problem.
I'm hoping for your help.

P.S.: Processors support VT-d (see specs).
The motherboard (I think) also supports this feature, as you can see this switch in the BIOS.


Configuration:
- Motherboard: HUANANZHI X99 DUAL-F8D (Specs)
- 2x CPU: Intel Xeon E5-2680 v4 (Specs)
- GPU: ROG Strix GeForce RTX 3060 V2 OC Edition 12GB (Specs)
 

Attachments

  • screen_1.jpg
    screen_1.jpg
    698.7 KB · Views: 78
  • screen_2.jpg
    screen_2.jpg
    36.5 KB · Views: 60
Result:
Code:
BOOT_IMAGE=/boot/vmlinuz-5.15.111-1-pve root=/dev/mapper/pve-root ro
As you can see, intel_iommu=on is not there and therefore IOMMU is not enabled by Proxmox. Add it according to the Proxmox manual (it is always needed for Intel, even on kernel 5.15 and higher). Make sure to apply your changes using the appropriate command for your bootloader.
 
Last edited:
Thanks for your help!
The whole problem was a typo :D
In the first message (step 2), the letter D in the word GRUB
 
Documentations states
you may also need to enable the IOMMU on the kernel command line for older (pre-5.15) kernels
which can misleading since this setting seems to be required on Intel systems in general. Since this comes up often on the forum (I did a brief search), can the documentation be updated?
 
Last edited:

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!