PCI Passthrough not working on HP ML310e Gen8


New Member
Jul 5, 2019
Hi, I've been trying to get PCI Passthrough to work on my HL ML310e Gen8 without any success for several days now I was hoping somebody here might have some ideas. I get this message in the log when attempting to start the VM:
Device is ineligible for IOMMU domain attach due to platform RMRR requirement.
PCI device is an IBM M1015 PCI SAS card flashed to IT mode.

I found this advisory from HP and followed the steps: (I can't post the link but the title is "(Revision) Linux - KVM Virtual Machine Does Not Start and Displays "Device is ineligible for IOMMU domain attach due to platform RMRR requirement" Message on HPE ProLiant Systems with an Intel Processor") Unfortunately it did not help. I also made sure I was on a newer firmware version than the article specified.

Next I found a suggestion to check the IOMMU groups and make sure it was in its own IOMMU group. I found that it was not, and moved it to another PCI-E slot and verified that it was now its own IOMMU group. Unfortunately that didn't resolve the issue.

I tried adding
per the wiki as well as
and neither of those options helped either.

I triple checked that VT-d was enabled. I've tried numerous suggestions I've found by googling that error message and nothing seems to help. Does anyone have any other suggestions to try?


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!