[SOLVED] Pci passthrough not working after reboot


New Member
Jun 28, 2023
Proxmox version 7.3-3

GPU Nvidia 3060ti, AMD 6600xt
CPU 5600x
Motherboard ASRock B550M Pro4

After a month or two of smooth(ish) sailing I rebooted my proxmox host because my vms were giving some weird behaviors, and when the host booted back up I was met with this error when the machines tried to boot up "TASK ERROR: cannot prepare PCI pass-through, IOMMU not present". I took a look at some other threads here I could find, but no answers that I could find. /etc/default/grub has these settings:

GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet amd_iommu=on iommu=pt pcie_acs_override=downstream,multifunction"

and my setup is definitely using grub as questioned by other threads, during boot it comes up with the gnu grub version and everything.
I don't remember the command but one thread asked the op to list the iommu groups to see if there were still multiple, and for me there were. If it would help I can post my specific output from my system.

Edit: ok i got some help from reddit, it was bios settings
Last edited:


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!