One time pve-zsync error.

ozgurerdogan

Renowned Member
May 2, 2010
605
5
83
Bursa, Turkey, Turkey
root@s4:~# pve-zsync sync --source 104 --dest 5.196.91.192 :p1 --verbose;
full send of rpool/data/vm-104-disk-1@rep_default_2018-12-17_23:11:27 estimated size is 101G
total estimated size is 101G
TIME SENT SNAPSHOT
23:17:07 44.3K rpool/data/vm-104-disk-1@rep_default_2018-12-17_23:16:09
23:17:08 44.3K rpool/data/vm-104-disk-1@rep_default_2018-12-17_23:16:09
23:17:09 44.3K rpool/data/vm-104-disk-1@rep_default_2018-12-17_23:16:09
23:17:10 44.3K rpool/data/vm-104-disk-1@rep_default_2018-12-17_23:16:09
23:17:11 44.3K rpool/data/vm-104-disk-1@rep_default_2018-12-17_23:16:09

COMMAND:
zfs send -v -- rpool/data/vm-104-disk-1@rep_default_2018-12-17_23:11:27 | ssh -o 'BatchMode=yes' root@5.196.91.192 -- zfs recv -F -- P1/vm-104-disk-1
GET ERROR:
cannot open 'P1/vm-104-disk-1': dataset does not exist
cannot receive new filesystem stream: dataset does not exist

But dataset exists!

Code:
root@s4:~# pveversion -v
proxmox-ve: 5.3-1 (running kernel: 4.15.18-9-pve)
pve-manager: 5.3-5 (running version: 5.3-5/97ae681d)
pve-kernel-4.15: 5.2-12
pve-kernel-4.15.18-9-pve: 4.15.18-30
pve-kernel-4.15.18-2-pve: 4.15.18-21
pve-kernel-4.15.18-1-pve: 4.15.18-19
corosync: 2.4.4-pve1
criu: 2.11.1-1~bpo90
glusterfs-client: 3.8.8-1
ksm-control-daemon: 1.2-2
libjs-extjs: 6.0.1-2
libpve-access-control: 5.1-3
libpve-apiclient-perl: 2.0-5
libpve-common-perl: 5.0-43
libpve-guest-common-perl: 2.0-18
libpve-http-server-perl: 2.0-11
libpve-storage-perl: 5.0-33
libqb0: 1.0.3-1~bpo9
lvm2: 2.02.168-pve6
lxc-pve: 3.0.2+pve1-5
lxcfs: 3.0.2-2
novnc-pve: 1.0.0-2
proxmox-widget-toolkit: 1.0-22
pve-cluster: 5.0-31
pve-container: 2.0-31
pve-docs: 5.3-1
pve-edk2-firmware: 1.20181023-1
pve-firewall: 3.0-16
pve-firmware: 2.0-6
pve-ha-manager: 2.0-5
pve-i18n: 1.0-9
pve-libspice-server1: 0.14.1-1
pve-qemu-kvm: 2.12.1-1
pve-xtermjs: 1.0-5
pve-zsync: 1.7-2
qemu-server: 5.0-43
smartmontools: 6.5+svn4324-1
spiceterm: 3.0-5
vncterm: 1.5-3
zfsutils-linux: 0.7.12-pve1~bpo1
 
does the pool/dataset 'P1' exist on the target?
 
please post the '/etc/pve/storage.cfg' and the ouput of
Code:
zpool list
zfs list

on both nodes
 
Source node:
Code:
root@s4:~# zpool list
NAME    SIZE  ALLOC   FREE  EXPANDSZ   FRAG    CAP  DEDUP  HEALTH  ALTROOT
P2     1.81T   284G  1.53T         -    27%    15%  1.00x  ONLINE  -
rpool  1.81T   794G  1.04T         -    31%    42%  1.00x  ONLINE  -

root@s4:~# zfs list
NAME                       USED  AVAIL  REFER  MOUNTPOINT
P2                         580G  1.19T    24K  /P2
P2/backups                  24K  1.19T    24K  /P2BACKUP
P2/vm-115-disk-1           103G  1.19T   101G  -
P2/vm-119-disk-1           307G  1.34T   151G  -
P2/vm-135-disk-1          78.2G  1.24T  21.1G  -
P2/vm-136-disk-1          92.2G  1.27T  9.21G  -
rpool                     1.20T   570G    96K  /rpool
rpool/ROOT                 570G   570G    96K  /rpool/ROOT
rpool/ROOT/pve-1           570G   570G   570G  /
rpool/data                 653G   570G    96K  /rpool/data
rpool/data/backups          96K   570G    96K  /P1BACKUP
rpool/data/vm-101-disk-1  28.6G   591G  7.21G  -
rpool/data/vm-104-disk-1   179G   673G  73.9G  -
rpool/data/vm-111-disk-1   181G   725G  25.8G  -
rpool/data/vm-117-disk-1   264G   725G   107G  -
rpool/swap                4.25G   571G  3.71G  -


zfspool: P1
    pool rpool/data
    content images,rootdir
    sparse 0

dir: local
    path /var/lib/vz
    content images,iso,vztmpl,rootdir
    maxfiles 0

dir: P1BACKUP
    path /P1BACKUP
    content vztmpl,rootdir,iso,images,backup
    maxfiles 1
    shared 0

zfspool: P2
    pool P2
    content rootdir,images
    sparse 0

dir: P2BACKUP
    path /P2BACKUP
    content rootdir,vztmpl,images,iso,backup
    maxfiles 2
    shared 0

Destination Node:
Code:
root@s3:~# zpool list
NAME    SIZE  ALLOC   FREE  EXPANDSZ   FRAG    CAP  DEDUP  HEALTH  ALTROOT
P2     1.81T   334G  1.49T         -    27%    17%  1.00x  ONLINE  -
rpool  1.81T   947G   909G         -    42%    51%  1.00x  ONLINE  -
root@s3:~# zfs list
NAME                       USED  AVAIL  REFER  MOUNTPOINT
P2                         576G  1.19T    24K  /P2
P2/backups                  24K  1.19T    24K  /P2BACKUP
P2/vm-114-disk-1           312G  1.34T   151G  -
P2/vm-116-disk-1           103G  1.24T  50.5G  -
P2/vm-125-disk-1           113G  1.19T   111G  -
P2/vm-134-disk-1          48.1G  1.23T  11.8G  -
rpool                     1.23T   542G    96K  /rpool
rpool/ROOT                 721G   542G    96K  /rpool/ROOT
rpool/ROOT/pve-1           721G   542G   721G  /
rpool/data                 530G   542G    96K  /rpool/data
rpool/data/backups          96K   542G    96K  /P1BACKUP
rpool/data/vm-100-disk-1   185G   645G  80.6G  -
rpool/data/vm-107-disk-1   168G   645G  62.7G  -
rpool/data/vm-109-disk-1   177G   645G  73.2G  -
rpool/swap                4.25G   542G  3.67G  -

zfspool: P1
    pool rpool/data
    content images,rootdir
    sparse 0

dir: local
    path /var/lib/vz
    content images,iso,vztmpl,rootdir
    maxfiles 0

dir: P1BACKUP
    path /P1BACKUP
    content vztmpl,rootdir,iso,images,backup
    maxfiles 1
    shared 0

zfspool: P2
    pool P2
    content rootdir,images
    sparse 0

dir: P2BACKUP
    path /P2BACKUP
    content rootdir,vztmpl,images,iso,backup
    maxfiles 2
    shared 0
 
on neither node have you a pool with name 'P1'
 
root@s4:~# pve-zsync sync --source 104 --dest 5.196.91.192:p1 --verbose;

with this command you want to sync to the pool 'P1'
but neither
Code:
root@s3:~# zpool list
NAME SIZE ALLOC FREE EXPANDSZ FRAG CAP DEDUP HEALTH ALTROOT
P2 1.81T 334G 1.49T - 27% 17% 1.00x ONLINE -
rpool 1.81T 947G 909G - 42% 51% 1.00x ONLINE -
nor
Code:
root@s4:~# zpool list
NAME SIZE ALLOC FREE EXPANDSZ FRAG CAP DEDUP HEALTH ALTROOT
P2 1.81T 284G 1.53T - 27% 15% 1.00x ONLINE -
rpool 1.81T 794G 1.04T - 31% 42% 1.00x ONLINE -
show a pool 'P1'
 
yes, but the storage config is irrelevant here if there is no zpool with that name there...
 
I always used this command. Anyway can you please write me command to move vm 104 I can try it.

Vm on P2 (which exists in zpool) can not be moved also.
root@s4:~# pve-zsync sync --source P2:115 --dest 5.196.91.192:p1 --verbose
VM 115 doesn't exist
 
Last edited:

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!