odd network behavior on VMs and CTs

Discussion in 'Proxmox VE: Networking and Firewall' started by Adam Dale, May 5, 2019.

  1. Adam Dale

    Adam Dale New Member

    Joined:
    May 5, 2019
    Messages:
    2
    Likes Received:
    0
    I don't even know where to start asking about this , I have searched for about 4 days everywhere.. About a week ago or so this started happening.

    The network speed test will do about 400Mbit/s down and only 4.09 or 4.10 up (the up is that EVERY TIME )

    I am on gigabit fiber with gig and 10g switches in the house.

    Transfering files internally to any of these vm or ct the TX rate caps at about 4Mbit/s or so internally ,

    I started troubleshooting this when my plex box that is on one of these VMs started saying the network was not fast enough and would drop ...

    Proxmox 5.3-8
    VMs are ubuntu 18.04 and CT is 18.04

    is there something that would restrict the upload/TX rate in the guest but not the host (the host promox server dosnt seem to be effected, I can TX/RX at full speeds)
     
  2. Adam Dale

    Adam Dale New Member

    Joined:
    May 5, 2019
    Messages:
    2
    Likes Received:
    0
    well here is an update....

    it looks like its something with ALL my ubuntu 18.04 installs.. even a physical machine I have in the house is doing the same thing.. now to figure out what the heck I have done :(

    installed a Debian CT and no issues..
     
  3. Dachshound

    Dachshound New Member
    Proxmox Subscriber

    Joined:
    Apr 2, 2017
    Messages:
    6
    Likes Received:
    1
    I had some issues with the network speed as well. I use a 1GB link, but had a transfer rate at 40KB/s to even nothing. After some testing, I figured out it is related to the network interface. In the first place I used the on board NIC where the admin interface is running as well. Than I used a PCIE NIC and it is running like charm.


    Host:
    Proxmox 5.4-3
    D3417-B2
    2x16GB Samsung M391A2K43BB1-CPB
    Intel Core i3-7100T
    sda: 120GB System-SSD -> System SSD
    sdb: 10TB Segate IronWolf (lvm-thin-pool) -> Backup HDD
    ssc: 8TB WesternDigital Red (OldScool straight mounting) -> active System (date storage)
    sdd: 500GB SSD (lvm-thin-pool) -> active System (system HDD)
    on board NIC: Intel i219-LM
    NIC 2: Intel 82574L
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. TheJM

    TheJM New Member

    Joined:
    May 3, 2019
    Messages:
    12
    Likes Received:
    0
    I am having the exact same issue. All of my 18.04 installs are getting about 300Mbps down and 4.13Mbps up. I have tried both NICs and got the same results.

    Did you ever figure out how to resolve your issue?
     
  5. TheJM

    TheJM New Member

    Joined:
    May 3, 2019
    Messages:
    12
    Likes Received:
    0
    What does a speedtest look like on your proxmox install as opposed to one of your VMs?

    I started this thread to try and resolve my issue. I am linking it here in case either one of us finds a solution.
    https://forum.proxmox.com/threads/upload-speed-issue.54840/#post-252803
     
  6. HologramX

    HologramX New Member

    Joined:
    May 7, 2019
    Messages:
    5
    Likes Received:
    0
    Same issue.. after some test ON SAME SERVER AND SAME LXC CONTAINER.. simple changing template , this was result:
    ALL S.O. other than ubuntu have no issue
    ALL ubuntu before and after 18 have no issue (14.X, 16.X 19.X)
    ALL ubuntu 18.X.X have same issue.. Download perfect.. UPLOAD limited: < 5Mbit..
    IF SOMEONE of proxmox team have an answer will be appreciated.
     
  7. bofh

    bofh Member

    Joined:
    Nov 7, 2017
    Messages:
    49
    Likes Received:
    7
    why would promos has an answer?
    you already said
    ubuntu 18 even on a physical machine has that issue. debians dont even as a vm.

    so my best guess is its ubuntu.
    maybe something with the default networking/driver whatever. maybe offload issue or some qos service?
    wouldnt be a big shock, i mean theres a reason why ubuntu doest have the best reputation for servers
     
  8. TheJM

    TheJM New Member

    Joined:
    May 3, 2019
    Messages:
    12
    Likes Received:
    0
    Please see my posts in this thread: https://forum.proxmox.com/threads/upload-speed-issue.54840/#post-254116
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice