[SOLVED] Not recognize boot order

chchia

Member
Aug 18, 2020
43
14
8
44
I had been getting this strange problem since 2 days ago.

i have a linux VM that i had been using for few months and it was ok, i restart it time to time and all was ok.

however, two days ago, when i restart, it goes in to UEFI interactive shell.
i tried to change the boot sequence (in webgui and in bios) and it is not helping, whatever i change it will back to always boot IDE0 CDROM first, then it boot UEFI. my disk either it is sata0 or virtio0 or scsi0 are all same cannot boot.

i deleted the VM and recreate, the first after installation is always ok, but the after reboot it always go to UEFI no matter what configuration i used, although i had been using such configuration for many months.

below is the package version.
i had delete and recreate the VM multiple time with different linux distro. all same result.

thanks in advance for any help and advise.

Code:
proxmox-ve: 6.2-2 (running kernel: 5.4.65-1-pve)
pve-manager: 6.2-15 (running version: 6.2-15/48bd51b6)
pve-kernel-5.4: 6.2-7
pve-kernel-helper: 6.2-7
pve-kernel-5.4.65-1-pve: 5.4.65-1
pve-kernel-5.4.60-1-pve: 5.4.60-2
pve-kernel-5.4.34-1-pve: 5.4.34-2
ceph-fuse: 12.2.11+dfsg1-2.1+b1
corosync: 3.0.4-pve1
criu: 3.11-3
glusterfs-client: 5.5-3
ifupdown: 0.8.35+pve1
ksm-control-daemon: 1.3-1
libjs-extjs: 6.0.1-10
libknet1: 1.16-pve1
libproxmox-acme-perl: 1.0.5
libpve-access-control: 6.1-3
libpve-apiclient-perl: 3.0-3
libpve-common-perl: 6.2-4
libpve-guest-common-perl: 3.1-3
libpve-http-server-perl: 3.0-6
libpve-storage-perl: 6.2-10
libqb0: 1.0.5-1
libspice-server1: 0.14.2-4~pve6+1
lvm2: 2.03.02-pve4
lxc-pve: 4.0.3-1
lxcfs: 4.0.3-pve3
novnc-pve: 1.1.0-1
proxmox-backup-client: 1.0.1-1
proxmox-mini-journalreader: 1.1-1
proxmox-widget-toolkit: 2.3-10
pve-cluster: 6.2-1
pve-container: 3.2-2
pve-docs: 6.2-6
pve-edk2-firmware: 2.20200531-1
pve-firewall: 4.1-3
pve-firmware: 3.1-3
pve-ha-manager: 3.1-1
pve-i18n: 2.2-2
pve-qemu-kvm: 5.1.0-6
pve-xtermjs: 4.7.0-2
qemu-server: 6.2-20
smartmontools: 7.1-pve2
spiceterm: 3.1-1
vncterm: 1.6-2
zfsutils-linux: 0.8.4-pve2
 
Last edited:

chchia

Member
Aug 18, 2020
43
14
8
44
if i get inside bios and select to boot from here, it will then boot correctly

but i cannot change the boot sequence, i tried to make changes for the boot order, however the next restart it always go back to boot DVD, the EFI shell, them harddisk

1605250069717.png
 
Last edited:

chchia

Member
Aug 18, 2020
43
14
8
44
update, i never consider to reboot Proxmox host due to i have 4 VM running on.

so today i tried reboot it, and it is now back to normal booting correctly.

i guess this can be close, just never thought that KVM needed such reboot.
 

HellMind Zmaster

Active Member
Jul 8, 2011
33
4
28
I m having this problem,
It seems if the boot order is set from gui proxmox it cant be changed within the vm. (or efibootmbr)
Now im trying to change the timeout and doesnt save it
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!