node adding with authkey error

informant

Active Member
Jan 31, 2012
728
8
38
Hi all,

i have add a node to a cluster and get thge error message: cant create autorized key...
i have check the folder in /etc/pve/priv

this doesn´t exist. i cant create him with mkdir i get permissions denied as root?

how can i add this node with the keys and how can i create tho folder correctly, well he doesn´t exist.
please help. very thanks

regards
 

informant

Active Member
Jan 31, 2012
728
8
38
Hello Dietmar,

we have reinstall the Server. After complete reinstall with DVD we have make a update to newest version.

Code:
pveversion -v
pve-manager: 2.2-32 (pve-manager/2.2/3089a616)
running kernel: 2.6.32-17-pve
proxmox-ve-2.6.32: 2.2-83
pve-kernel-2.6.32-16-pve: 2.6.32-82
pve-kernel-2.6.32-17-pve: 2.6.32-83
lvm2: 2.02.95-1pve2
clvm: 2.02.95-1pve2
corosync-pve: 1.4.4-1
openais-pve: 1.1.4-2
libqb: 0.10.1-2
redhat-cluster-pve: 3.1.93-2
resource-agents-pve: 3.9.2-3
fence-agents-pve: 3.1.9-1
pve-cluster: 1.0-34
qemu-server: 2.0-72
pve-firmware: 1.0-21
libpve-common-perl: 1.0-41
libpve-access-control: 1.0-25
libpve-storage-perl: 2.0-36
vncterm: 1.0-3
vzctl: 4.0-1pve2
vzprocps: 2.0.11-2
vzquota: 3.1-1
pve-qemu-kvm: 1.3-10
ksm-control-daemon: 1.1-1

bevore we add node
ls -l /etc/pve
Code:
:/etc/pve# ls
authkey.pub  datacenter.cfg  local  nodes  openvz  priv  pve-root-ca.pem  pve-www.key  qemu-server  user.cfg  vzdump.cron

and after add:
Code:
ls -l /etc/pve
ls: Zugriff auf /etc/pve nicht möglich: Der Socket ist nicht verbunden


and than:

We have add than the node and get this error message:

Code:
copy corosync auth key
stopping pve-cluster service
Stopping pve cluster filesystem: pve-cluster.
backup old database
Starting pve cluster filesystem : pve-clusterfuse: failed to access mountpoint /etc/pve: Transport endpoint is not connected
[main] crit: fuse_mount error: Transport endpoint is not connected
[main] notice: exit proxmox configuration filesystem (-1)
 (warning).
cannot stat initial working directory for /etc/pve: Der Socket ist nicht verbunden at /usr/bin/pvecm line 480
starting pve-cluster failed

What can we do. Can you help us please?

reagards
 

tom

Proxmox Staff Member
Staff member
Aug 29, 2006
15,525
911
163
can you post full detail? what command to run to join and the full output.
 

informant

Active Member
Jan 31, 2012
728
8
38
yes sure,

i use following command:

Code:
 pvecm add 217.69.*.67
The authenticity of host '[217.69.*.67]:24224([217.69.*.67]:24224)' can't be established.
RSA key fingerprint is e2:b7:44:ee:be:71:58:3e:c2:41:e9:4c:d3:4d:78:0a.
Are you sure you want to continue connecting (yes/no)? yes
root@217.69.*.67's password:
copy corosync auth key
stopping pve-cluster service
Stopping pve cluster filesystem: pve-cluster.
backup old database
Starting pve cluster filesystem : pve-clusterfuse: failed to access mountpoint /etc/pve: Transport endpoint is not connected
[main] crit: fuse_mount error: Transport endpoint is not connected
[main] notice: exit proxmox configuration filesystem (-1)
 (warning).
cannot stat initial working directory for /etc/pve: Der Socket ist nicht verbunden at /usr/bin/pvecm line 480
starting pve-cluster failed


after reboot the list:
Code:
ls -l /etc/pve
insgesamt 5
-rw-r----- 1 root www-data  451 17. Feb 19:57 authkey.pub
-rw-r----- 1 root www-data  234 21. Feb 19:12 cluster.conf
-rw-r----- 1 root www-data  282 21. Feb 19:12 cluster.conf.old
-rw-r----- 1 root www-data   13 17. Feb 19:46 datacenter.cfg
lrwxr-x--- 1 root www-data    0  1. Jan 1970  local -> nodes/titan
drwxr-x--- 2 root www-data    0 17. Feb 19:57 nodes
lrwxr-x--- 1 root www-data    0  1. Jan 1970  openvz -> nodes/titan/openvz
drwx------ 2 root www-data    0 17. Feb 19:57 priv
-rw-r----- 1 root www-data 1533 17. Feb 19:57 pve-root-ca.pem
-rw-r----- 1 root www-data 1679 17. Feb 19:57 pve-www.key
lrwxr-x--- 1 root www-data    0  1. Jan 1970  qemu-server -> nodes/titan/qemu-server
-rw-r----- 1 root www-data  140 20. Feb 14:10 storage.cfg
-rw-r----- 1 root www-data  369 20. Feb 19:35 user.cfg
-rw-r----- 1 root www-data  119 17. Feb 19:57 vzdump.cron

regards
 
Last edited:

dietmar

Proxmox Staff Member
Staff member
Apr 28, 2005
17,114
513
133
Austria
www.proxmox.com
Seem you had some open files in /etc/pve when you start the command.

Make sure to close all files from /etc/pve, and make sure the working directory of all shells is outside of /etc/pve/

Else we cannot restart/remount the fuse file system at /etc/pve
 

informant

Active Member
Jan 31, 2012
728
8
38
OK,

we have reboot the maschine, but after this and add again the cluster.conf on cluster srever is lost? where can i reconfigure the cluster.conf on cluster server. cman and pve-cluster service was restartet without result. waht can i do to reconfigure the missing cluster.conf on cluster server?

regards

new entry:

i have rcreate a cluster with following way:

cp -a /etc/pve /root/pve_backup
/etc/init.d/pve-cluster stop
umount /etc/pve
/etc/init.d/cman stop
# rm /etc/cluster/cluster.conf
# rm -rf /var/lib/pve-cluster/*
/etc/init.d/pve-cluster start
# pvecm create newcluster
# cp /root/pve_backup/*.cfg /etc/pve/
# cp /root/pve_backup/qemu-server/*.conf /etc/pve/qemu-server/
# cp /root/pve_backup/openvz/* /etc/pve/openvz/

cluster:
after this i get the error message if i click to add/change/remove a user or click on a vm: permission denied - invalid ticket (401)
the same i get if i would login with other user account by proxmox users..
what can i do here? please help. very thanks.

last entry in syslog:

Feb 22 11:18:02 pegasus pmxcfs[953719]: [status] crit: cpg_send_message failed: 9
Feb 22 11:18:02 pegasus pmxcfs[953719]: [status] crit: cpg_send_message failed: 9
Feb 22 11:18:02 pegasus pmxcfs[953719]: [status] crit: cpg_send_message failed: 9
Feb 22 11:18:02 pegasus pmxcfs[953719]: [status] crit: cpg_send_message failed: 9
Feb 22 11:18:02 pegasus pmxcfs[953719]: [status] crit: cpg_send_message failed: 9


i have restart the pve-manager
the permission denied error is solved. but i must recreate all proxmox users new. why i cant use the existing users? -> Fix: i must set the password new for all users...

after this i have readd the node with this command:
Code:
 pvecm add 217.69.*.67
root@217.69.*.67's password:
copy corosync auth key
stopping pve-cluster service
Stopping pve cluster filesystem: pve-cluster.
backup old database
Starting pve cluster filesyste[B]m : pve-clustercan't create shared ssh key database '/etc/pve/priv/authorized_keys'[/B]
.
Starting cluster:
   Checking if cluster has been disabled at boot... [  OK  ]
   Checking Network Manager... [  OK  ]
   Global setup... [  OK  ]
   Loading kernel modules... [  OK  ]
   Mounting configfs... [  OK  ]
   Starting cman... [  OK  ]
   Waiting for quorum... [  OK  ]
   Starting fenced... [  OK  ]
   Starting dlm_controld... [  OK  ]
   Tuning DLM kernel config... [  OK  ]
   Unfencing self... [  OK  ]
generating node certificates
merge known_hosts file
restart services
Restarting PVE Daemon: pvedaemon.
Restarting web server: apache2 ... waiting .
successfully added node 'titan' to cluster.

How can i fix this error, if the node can´t write a authkey?

regards and very thanks
 
Last edited:

informant

Active Member
Jan 31, 2012
728
8
38
Hi,

anywhere a idea to fix the issue with authcode error? we have access to the nodes, but everytime on adding we have this error, that the authkey can´t save?

regards
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!