no VNC failure with reverse proxy

Vtsax

New Member
Oct 11, 2023
3
2
3
Hello,

I hope I'm not bothering you, but I need your assistance. I've successfully set up a Proxmox server (8.0.3) on an old PC, and everything went smoothly.
Subsequently, I created a virtual machine with Windows 11.

I can access it internally without any issues, and noVNC starts without a problem.
However, things get complicated when I try to use reverse proxy (Synology NAS) to start VM .

I can access the Proxmox interface via HTTPS without any problems, but I can't seem to open the VM consoles.
It gives me a network error.

I'm not an expert in this field, and it's relatively newbie
Do you know if there's a solution for this issue? I came across a procedure here , but I'm unsure how to apply it or if it's the right solution.

Thank you very much for your assistance.
 

Attachments

  • Capture d'écran 2023-10-14 113310.png
    Capture d'écran 2023-10-14 113310.png
    31.2 KB · Views: 7
Hi,

For future reference, the solution in your case is to activate Websocket support in your reverse proxy.
In DSM latest versions :

synology-09-702x300.png

synology-10-702x299.png


credits to this blog post (in french)
 
  • Like
Reactions: akulbe and Vtsax

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!