No network after upgrading to latest kernel (pve 5.4)

limone

Member
Aug 1, 2017
72
0
11
25
Hi, when I upgraded to the newest kernel (4.15.18-23-pve) the machine cannot find interface ens3 anymore.
I wanted to upgrade to 6.0, but I guess thats only working when you're on the latest kernel.

If i boot into 4.15.18-15 everything works fine.

Code:
auto lo
iface lo inet loopback

allow-hotplug ens3
iface ens3 inet static
        address  123.123.123.123
        netmask  255.255.255.0
        gateway  123.123.123.1

        post-up "ip addr a 111.111.111.111/32 dev ens3"
by the way pve5to6 shows "FAIL: Resolved node IP '123.123.123.123' not configured or active for 'pve'"
but my /etc/hosts is
Code:
127.0.0.1       localhost
123.123.123.123  pve.example.org   pve     pvelocalhost

# The following lines are desirable for IPv6 capable hosts
::1     localhost ip6-localhost ip6-loopback
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters
any idea how to debug that? i could'nt find anything suspicious in syslog or dmesg
 

Stoiko Ivanov

Proxmox Staff Member
Staff member
May 2, 2018
2,295
240
63
Hmm - on a hunch - maybe ens13 got renamed with the kernel-upgrade (usually this happens sometimes with BIOS upgrades, but I think I remember a case where a kernel-update changed the predictable network name [0])

boot into the newest kernel and run:
Code:
ip link
ip a
that should show you which name all network devices have - if it changed adapt /etc/network/interfaces accordingly

I hope this helps!
[0]https://www.freedesktop.org/wiki/Software/systemd/PredictableNetworkInterfaceNames/
 

limone

Member
Aug 1, 2017
72
0
11
25
Thanks, it changed to eth0.
I don't know if there was a bios update, as it's just a kvm which i run proxmox on, maybe the host did the updates.

I saw in dmesg (i think) that eth0 was renamed to ens3, so i thought everything is as it's supposed to be.
ip a didnt show ens3 or eth0, probably because it wasn't configured.
 

Stoiko Ivanov

Proxmox Staff Member
Staff member
May 2, 2018
2,295
240
63
Thanks, it changed to eth0.
That's odd and usually means some manual configuration in a systemd config file (overriding the default from '/lib/systemd/network/99-default.link')

AFAIR the upgrade to PVE6/Debian buster depracates the old network names (eth0,...) - so maybe try to get that fixed

I hope this helps!
 

limone

Member
Aug 1, 2017
72
0
11
25
Hmm I didnt change anything, the content is
Code:
[Link]
NamePolicy=kernel database onboard slot path
MACAddressPolicy=persistent
I'll just see what happens after upgrading to 6 :)
 

limone

Member
Aug 1, 2017
72
0
11
25
Okay the upgrade went fine, but for some reason all my post-up rules don't work anymore, e.g.

Code:
auto vmbr0
iface vmbr0 inet static
    address  10.10.10.1
    netmask  255.255.255.0
    bridge-ports none
    bridge-stp off
    bridge-fd 0

    post-up   iptables -t nat -A POSTROUTING -s '10.10.10.0/24' -o eth0 -j MASQUERADE
    post-down iptables -t nat -D POSTROUTING -s '10.10.10.0/24' -o eth0 -j MASQUERADE
any idea why? network interface is still eth0


nevermind another reboot fixed it
 
Last edited:

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE and Proxmox Mail Gateway. We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!