[SOLVED] No Local-LVM after automated install

Servoz99

New Member
Sep 18, 2026
3
2
3
Hello,

I'm using automated install to setup a new pve host with iso proxmox-ve_9.2-1.iso.
All my attempts failed. The node is setup but the local-lvm is not created.
root@pve02:~# lsblk
NAME MAJ:MIN RM SIZE RO TYPE MOUNTPOINTS
sda 8:0 0 119.2G 0 disk
├─sda1 8:1 0 1007K 0 part
├─sda2 8:2 0 1G 0 part /boot/efi
└─sda3 8:3 0 118.2G 0 part
├─pve-swap 252:0 0 4G 0 lvm [SWAP]
└─pve-root 252:1 0 114.2G 0 lvm /

Wathever the config is, it always failed.
Any idea on what I'm missing ?
 

Attachments

From the lsblk output, it looks like only pve-root and pve-swap are present, and almost the entire VG was allocated to pve-root. That might explain why the LVM-thin data volume / local-lvm was not created.

Could you please paste the relevant disk setup section of your answer.toml directly into the thread?
 
Hello,

Here is the disk setup section from the toml file :
[disk-setup]
filesystem = "ext4"
disk_list = ["sda"]
# lvm.hdsize = 119
# lvm.swapsize = 4
# lvm.maxroot = 25
# lvm.minfree = 16

The commented lines were used for my different tests.
I made new tests this morning, the result is the same with iso 9.1-1, and with the latest version of proxmox-auto-install-assistant (v9.2.8)
 
My bad, in the post install script I was recreating the LVM in order to have the same configuration on all proxmox nodes. But this configuration was for a disk over 512GB.
When the script is disabled, everything runs fine.