No bootable media found after installation


New Member
Jul 1, 2023
Hi All,

I've recently purchased a HPE ProLiant Microserver Gen10 server with 4 HDDs, and would like to try out Proxmox (completely new to Proxmox). I've downloaded the Proxmox 8.0 ISO Installer and put this on a bootable USB (have tried both Rufus and Etcher).

The server boots with UEFI and picks up the USB fine, I proceed with the install and set the details I want etc. Then at the end it reboots to start up the Proxmox instance on the server and asks you to remove the USB.

This is where my problems start, no bootable media is then found. I've tried installing defaults to just one disk and also selecting ZFS RAID10 an letting it format everything. Still no media is found, I've looked online and found some similar posts but they were either different issues or the thread was marked resolved.

Proxmox is showing in my boot menu, but I still can't boot from it. I've opened up the Embedded Shell on my HP Server and can see the Proxmox boot option in:
- HD (2, GPT, long serial number) /\EFI\proxmox\grubx64.efi

Any advice please?

For reference:
Secure boot is disabled
Virtualization is enabled
No HP SSA Raid has been setup
Last edited:


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!