[SOLVED] New Proxmox host, Linux guests hang during install


New Member
Dec 29, 2018

I've just purchased a new box to be a Proxmox host. Details are;
  • Core i7 8700 CPU
  • 32Gb RAM
  • 1 of M.2 240Gb disk
  • 3 of SATA 1Tb SSD
  • 1 of SATA 2Tb HDD
  • MSI H370M MB
The 3 1Tb SSDs are in a ZFS pool, which I plan to use to hold the guest volumes. The HDD is for backups and maybe some larger disk volumes to present to guests that need to store a bit of data. The 240Gb M.2 will just be an OS disk for Proxmox.

I have created an OpenVSwitch switch, and added the NIC as a OVS Port. I have an OVS IntPort and am able to access the host webgui on this IP. All guests are in the same VLAN, but I need to put guests into different or multiple VLANs at a later date.

I have attempted to build VMs from the Ubuntu 18.10 & 18.04.2 install media, as well as Fedora 29. All hang with high CPU load during the install. The mouse pointer just stops moving.

For testing, I span up a Win10 VM. The Win10 box installed without issue and looks like it's currently patching.

All VMs are assigned the following virtual hardware;
  • 2/4 cores, 1 socket
  • 1Gb RAM
  • A single, 32Gb disk presented from the ZFS pool.
  • A single NIC in the same VLAN as the OVS IntPort.
I'm not sure what my issue is, so far I've tried;
  • Checking the CPU virtualisation features (VT-d was disabled in the BIOS during the Proxmox install - now enabled).
  • Changing NIC types;
    I've tried VirtIO and Intel so far.
  • Changing storage types;
    I've tried SCSI and SATA so far.
  • Changing emulated CPU types;
    Tried default (kvm64) and Sandy Bridge.
Is anybody able to offer assistance?

All hang with high CPU load during the install. The mouse pointer just stops moving.
Can you post the configuration files for your VMs which fail? Just to see what kind of settings you have and how much resource is allocated.
qm config VMID

I can't really think of anything off the top of my head, but did you try using the non-graphical install mode on the Ubuntu installer?

Also what are your PVE package versions?

pveversion -v
  • Like
Reactions: andy72
Hmmm, I'm using the LiveCD installer in all (failed) cases.

I did go on and install a couple of Ubuntu server installs, which worked without issue.

Is it likely to be video (or something) drivers? I never get a chance to replace the defaults with anything VirtIO.

Config details (I snipped some details);
root@[HOST-NAME]:~# qm config 900
agent: 1
bootdisk: scsi0
cores: 2
ide2: local:iso/ubuntu-18.10-desktop-amd64.iso,media=cdrom
memory: 1024
name: [GUEST-NAME]
net0: virtio=2A:8C:A9:2C:40:8E,bridge=vmbr1,tag=[VLAN-NUMBER]
numa: 0
ostype: l26
scsi0: ssdtank:vm-900-disk-0,size=10G
scsi1: ssdtank:vm-900-disk-1,size=5G
scsi2: ssdtank:vm-900-disk-2,size=5G
scsihw: virtio-scsi-pci
smbios1: uuid=b05121f2-a163-4681-94da-5f551dd4249f
sockets: 1
vmgenid: bad81895-26d7-4929-811d-841e4ee941f9

root@[HOST-NAME]:~# pveversion -v
proxmox-ve: 5.3-1 (running kernel: 4.15.18-12-pve)
pve-manager: 5.3-11 (running version: 5.3-11/d4907f84)
pve-kernel-4.15: 5.3-3
pve-kernel-4.15.18-12-pve: 4.15.18-35
pve-kernel-4.15.18-9-pve: 4.15.18-30
corosync: 2.4.4-pve1
criu: 2.11.1-1~bpo90
glusterfs-client: 3.8.8-1
ksm-control-daemon: 1.2-2
libjs-extjs: 6.0.1-2
libpve-access-control: 5.1-3
libpve-apiclient-perl: 2.0-5
libpve-common-perl: 5.0-47
libpve-guest-common-perl: 2.0-20
libpve-http-server-perl: 2.0-12
libpve-storage-perl: 5.0-39
libqb0: 1.0.3-1~bpo9
lvm2: 2.02.168-pve6
lxc-pve: 3.1.0-3
lxcfs: 3.0.3-pve1
novnc-pve: 1.0.0-3
openvswitch-switch: 2.7.0-3
proxmox-widget-toolkit: 1.0-23
pve-cluster: 5.0-33
pve-container: 2.0-35
pve-docs: 5.3-3
pve-edk2-firmware: 1.20181023-1
pve-firewall: 3.0-18
pve-firmware: 2.0-6
pve-ha-manager: 2.0-8
pve-i18n: 1.0-9
pve-libspice-server1: 0.14.1-2
pve-qemu-kvm: 2.12.1-2
pve-xtermjs: 3.10.1-2
qemu-server: 5.0-47
smartmontools: 6.5+svn4324-1
spiceterm: 3.0-5
vncterm: 1.5-3
zfsutils-linux: 0.7.13-pve1~bpo1
  • Like
Reactions: andy72
I think this was caused by the liveCD video drivers or something - I'll try it again at some point.


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!