[SOLVED] Networking Configuration!

YaseenKamala

Member
Feb 2, 2021
132
2
18
37
Dear All,

Currently I am facing a problem on a proxmox hypervisor node. I don't have access to the web interface using the IP address mentioned in the welcome message followed by the port number 8006. I even don't have PING.
I checked the configuration within /etc/network/interfaces, it is the same IP i get from the welcoming window and the other related configuration like gateway, address mask, etc.
I also checked the hosts files within /etc/hosts I have the IP address followed by the machine name and its domain.

Could you please help me ? Do you have an idea on what else I should check to fix this problem ?

Best regards
 

oguz

Proxmox Staff Member
Staff member
Nov 19, 2018
5,207
676
118
hi,

are you accessing the interface like https://your.ip.address.here:8006 (don't forget S on httpS)?

you can check if the GUI port is listening by running ss -anto| grep 8006. if that's not running then you should check your journalctl output for errors

hope this helps
 
  • Like
Reactions: YaseenKamala

YaseenKamala

Member
Feb 2, 2021
132
2
18
37
hi,

are you accessing the interface like https://your.ip.address.here:8006 (don't forget S on httpS)?

you can check if the GUI port is listening by running ss -anto| grep 8006. if that's not running then you should check your journalctl output for errors

hope this helps
Hello @oguz thank you very much for your reply.
not I don't have access to https://your.ip.address.here:8006 neither ssh and even I can't ping to it! I am going to share the screenshots. this way we can see better.
 

YaseenKamala

Member
Feb 2, 2021
132
2
18
37
Hello @oguz bellow are some screenshots of the configuration that I have however I just realized within the interface file the DHCP was still active as you can see and I have commented out. but I was wandering if we could force the change without restarting the server???!!!

thanking you in advance for your help.

Best regards.
 

Attachments

  • interfaces-config.png
    interfaces-config.png
    462 KB · Views: 8
  • hosts.png
    hosts.png
    332.6 KB · Views: 8
  • welcome-window.png
    welcome-window.png
    720.6 KB · Views: 8

YaseenKamala

Member
Feb 2, 2021
132
2
18
37
and when I try to see what is the network configuration suing ip a command I don't see any IP@ !
 

Attachments

  • ipa.png
    ipa.png
    644.5 KB · Views: 8

oguz

Proxmox Staff Member
Staff member
Nov 19, 2018
5,207
676
118
but I was wandering if we could force the change without restarting the server???!!!
systemctl restart networking should restart networking service.

afterwards try pinging your gateway IP from the server and see if it works then
 
  • Like
Reactions: YaseenKamala

YaseenKamala

Member
Feb 2, 2021
132
2
18
37
Indeed it worked like a charm :) thank you so much for the great help I really appreciated.

Have a nice day.
 

oguz

Proxmox Staff Member
Staff member
Nov 19, 2018
5,207
676
118
great, please mark the thread [SOLVED] by clicking "Edit Thread" on top right :)
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!