[SOLVED] Network state DOWN after update & reboot

dust_bro

Member
Nov 25, 2021
23
0
6
46
My networks seems to be jammed up after I did an update and rebooted.

ip a:
Code:
1: lo <LOOPBACK, UP, LOWER_UP> mtu 65536 qdisc nonqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
      valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host
      valid_lft forever preferred_lft forever
2: enp5s0: <BROADCAST, MLITICAST> mtu 1500 qdisc noop state DOWN group default qlen 1000
    link/ether d8:bb:c1:37:02:bc brd ff:ff:ff:ff:ff:ff

/etc/network/interfaces :
Code:
auto lo
iface lo inet loopback

auto enp5s0
iface enp5s0 inet manual

auto vmbr0
iface vmbr0 inet static
      address 192.168.1.231/24
      gateway 192.168.1.1
      bridge-ports enp5s0
      bridge-stp off
      bridge-fd 0

If I run "ip link set dev enp5s0 up" I get:

Code:
2: enp5s0: <BROADCAST, MLITICAST> mtu 1500 qdisc noop state UP group default qlen 1000
    link/ether d8:bb:c1:37:02:bc brd ff:ff:ff:ff:ff:ff
    inet6 fe08:dabb:c1ff:fe37:2bc/64 scope link
      valid_lft forever preferred_lft forever

If I try to ping 192.168.1.1 I get "Network is unreachable"

What do you suggest I try next?
 
Hi,

are there any error/warning messages in the syslog (journalctl -b), that might indicate what went wrong?
If you're unsure, you can also just attach the whole log as a file.

Can you also please post the output of pveversion -v?
 
I appreciate the reply. Hopefully you see something in here, cause it's not apparent to me.

pveversion -v
Code:
proxmox-ve: 7.3-1 (running kernel: 6.1.10-1-pve)
pve-manager: not correctly installed (running version: 7.3-6/723bb6ec)
pve-kernel-6.1: 7.3-4
pve-kernel-helper: 7.3-4
pve-kernel-5.15: 7.3-2
pve-kernel-5.19: 7.2-15
pve-kernel-6.1.10-1-pve: 6.1.10-1
pve-kernel-5.19.17-2-pve: 5.19.17-2
pve-kernel-5.19.17-1-pve: 5.19.17-1
pve-kernel-5.19.7-2-pve: 5.19.7-2
pve-kernel-5.15.85-1-pve: 5.15.85-1
pve-kernel-5.15.83-1-pve: 5.15.83-1
pve-kernel-5.15.74-1-pve: 5.15.74-1
pve-kernel-5.15.64-1-pve: 5.15.64-1
pve-kernel-5.15.30-2-pve: 5.15.30-3
ceph-fuse: 15.2.16-pve1
corosync: 3.1.7-pve1
criu: 3.15-1+pve-1
glusterfs-client: 9.2-1
ifupdown2: not correctly installed
ksm-control-daemon: 1.4-1
libjs-extjs: 7.0.0-1
libknet1: 1.24-pve2
libproxmox-acme-perl: not correctly installed
libproxmox-backup-qemu0: 1.3.1-1
libpve-access-control: not correctly installed
libpve-apiclient-perl: 3.2-1
libpve-common-perl: not correctly installed
libpve-guest-common-perl: not correctly installed
libpve-http-server-perl: not correctly installed
libpve-storage-perl: not correctly installed
libspice-server1: 0.14.3-2.1
lvm2: 2.03.11-2.1
lxc-pve: 5.0.2-1
lxcfs: 5.0.3-pve1
novnc-pve: 1.3.0-3
proxmox-backup-client: not correctly installed
proxmox-backup-file-restore: not correctly installed
proxmox-mail-forward: 0.1.1-1
proxmox-mini-journalreader: 1.3-1
proxmox-offline-mirror-helper: 0.5.1-1
proxmox-widget-toolkit: 3.5.5
pve-cluster: not correctly installed
pve-container: 4.4-2
pve-docs: 7.3-1
pve-edk2-firmware: 3.20220526-1
pve-firewall: 4.2-7
pve-firmware: 3.6-3
pve-ha-manager: not correctly installed
pve-i18n: 2.8-2
pve-qemu-kvm: 7.1.0-4
pve-xtermjs: 4.16.0-1
qemu-server: 7.3-3
smartmontools: 7.2-pve3
spiceterm: 3.2-2
swtpm: 0.8.0~bpo11+2
vncterm: 1.7-1
zfsutils-linux: 2.1.9-pve1


Logs attached.
 

Attachments

  • all_logs.txt
    216.2 KB · Views: 3
proxmox-ve: 7.3-1 (running kernel: 6.1.10-1-pve)
First of, I'd advise you to upgrade, at least to 7.4, as soon as this is fixed and you have network access again.

pve-manager: not correctly installed (running version: 7.3-6/723bb6ec)
ifupdown2: not correctly installed
Did you recently used apt to install/remove something?

To explain, the root cause here is that the vmbr0 bridge is not created/brought up - thus the physical link (enp5s0) also never gets activated. This is probably caused by the absence/incorrect installation of the ipupdown2 package.

If there is a local cached version of the package (i.e. if ls -lah /var/cache/apt/archives/ifupdown2* returns a file), you can try re-installing that using apt install -f /var/cache/apt/archives/ifupdown[..].deb.

Next, you can also try running ifreload -a (if the command exists) and see if that brings up the bridge.

Otherwise, you best guess is probably download ifupdown2_3.1.0-1%2Bpmx4_all.deb, transferring that onto the machine using e.g. a flash drive, install it using apt install -f <path-to-file> and reboot.
 
  • Like
Reactions: dust_bro
Did you recently used apt to install/remove something?
My Hero!
This was the culprit. I used apt to update the system. I guess that is not recommended?
Luckily, there was a cached version of ifupdown on the system so a quick reinstall got me back up and running.
 
Great to hear that solved it!

I used apt to update the system. I guess that is not recommended?
No, it is the recommended way. What commands did you use to update your system?
It is important to always use apt dist-upgrade, not e.g. apt upgrade.

See also the System Software Updates section in our documentation/admin guide.
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!