[SOLVED] Network not working after failed update

Lxndr

New Member
Aug 28, 2021
9
3
1
49
Hi all,

I tried updating my Proxmox 7 from the web page, at first all looked fine so I left it running, next day when I tried to log in without success, so decided to reboot the machine, it booted fine telling me that I could go to the web page, but still no access from the web page.

I checked the network interfaces and the showed up down, so tried to bring them back up but got a permission denied message, so tried ip link set XXXX up to bring my 2 interfaces that are bridged which seemed to work but I still have no network connectivity.

I don't know what else I can try to get the system back up and connected to the network, or where to look at the logs to know what's really going on for the network not to come up, I've also tried running systemctl to restart the network service, that changes nothing.

Any ideas of the root cause of this or what I can do to resolve it?

Thanks
 
Thanks but looking in the log directory I don't have ifupdown2 in there.
 
Seems like I was stuck due to dpkg being blocked, after running dpkg --configure -a and then rebooting once if was finished, I was able to log back in via the web gui.
Thanks a lot, this helped me! Now proxmox will update only via ipmi/ilo or non-remotely:)
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!