Nested ESXi 8.0 on PVE 8.0 host

acidrop

Renowned Member
Jul 17, 2012
204
6
83
Trying to install ESXi v8.0 as a nested VM on a PVE 8.0 host, but the installer fails at the installation phase with the following error:

"Disk device does not support OSDATA"

(see attached screenshots)

According to VMware [1] the above message is shown when the installer detects the local disk used for the installation as a sd card or s usb disk (i.e non peristent disk). However, this is not the case here as I'm using SATA or IDE disk for the setup.

Any ideas ?

Thanks

[1]
https://kb.vmware.com/s/article/85615
 

Attachments

  • IMG_4492.jpeg
    IMG_4492.jpeg
    250.2 KB · Views: 22
  • IMG_4493.jpeg
    IMG_4493.jpeg
    150.7 KB · Views: 21
You mean the installer was able to detect the disk and then install ESXi normally ?
 
Ok, I tried installing a different ESXi version (7.0.3) and this time it succeeded (on a SATA vdisk). So the issue must be ESXi v8.0/PVE v8.0 specific.

Thanks
 
I hit the very same issue while on Qemu/KVM with libvirt - only have tried esxi 8.x though. Qemu 8.1.0
 
I reproduced the OSData problem with ESXi 8 and PVE 7. As far as I understood, the OSData disk has to be of a minimum size, so having a too small disk for installing ESXi will result in the error. This has been true for ESXi 7, too. More information can be found here. If you choose a bigger disk, the installer will just work. I tried the workaround in the article with a smaller disk, but was not able to circumvent the error. I used a 64G disk and it just went through the installer.
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!